The mailbox location could not be determined error occurs with Server-Side Synchronization in Microsoft Dynamics CRM 2013

This article provides a solution to an error that occurs when you configure Server-Side Synchronization for your Microsoft Dynamics CRM 2013 organization and use the Auto Discover Server Location option.

Applies to:   Microsoft Dynamics CRM Online, Microsoft Dynamics CRM 2013
Original KB number:   2972143

Symptoms

When you configure Server-Side Synchronization for your Microsoft Dynamics CRM 2013 organization, and use the Auto Discover Server Location option, you see an Alert generated with the following message:

"The mailbox location could not be determined while receiving email"

This issue may occur intermittently if you're using an Exchange Email Server Profile and the Auto Discover Server Location option.

Cause

This issue can occur because of an Auto Discover issue identified with Microsoft Exchange.

Resolution

Microsoft is aware of this issue and plans to address it in a future update. In the meantime, you can use your Exchange web services URL instead of using the Auto Discover Server Location option within your Email Server Profile.

  1. Open the Microsoft Dynamics CRM web application.
  2. On the navigation bar, select Microsoft Dynamics CRM and then select Settings.
  3. On the navigation bar, select Settings and then select Email Configuration.
  4. Select Email Server Profiles.
  5. Open your Email Server Profile.
  6. Change the Auto Discover Server Location to No.
  7. Within the Incoming Server Location and Outgoing Server Location fields, enter your Exchange Web Services URL for your Exchange organization.
  8. Select Save.