Note
Access to this page requires authorization. You can try signing in or changing directories.
Access to this page requires authorization. You can try changing directories.
This article provides a resolution to solve the Database Connector Error: 'Hy010:[Microsoft][ODBC Driver Manager] error that occurs in Microsoft Dynamics SL.
Applies to: Microsoft Dynamics SL 2011, Microsoft Dynamics SL 2011 Service Pack 1, Microsoft Dynamics SL 2011 Service Pack 2, Microsoft Dynamics SL 2015
Original KB number: 3062462
Symptoms
Consider the following scenario in Microsoft Dynamics SL:
- Create an invoice in the Invoice and Adjustment Maintenance (BI.BAM) screen and then write off this invoice.
- From the Invoice and Adjustment Maintenance (BI.BAM) screen, select View Invoice. You will receive this error.
- When you try to final print or Print Preview this zero invoice from the Invoice Print (BI.INV) report, you also receive this error:
Database Connector Error: 'Hy010:[Microsoft][ODBC Driver Manager]
Function sequence error'
Error in File BIXXX.rpt:
Database Connector Error: 'Hy010:[Hy010:[Microsoft][ODBC Driver Manager]
Function sequence error'
Cause
This occurs when the PJINVDet line = "0"
and in_id18 = NP
.
Resolution
With this workaround, the page will be completely blank:
- Open the report in Crystal Reports.
- Select File and then select Report options.
- Check the box on the right side Suppress Printing if no records.
- Save and close the report.