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"System Message 10232" error when signing in to Microsoft Dynamics SL

This article provides a solution to a System Message 10232 error when you try to sign in to Microsoft Dynamics SL.

Applies to:   Microsoft Dynamics SL 2011
Original KB number:   2780548

Symptoms

When you try to sign in to Microsoft Dynamics SL, you receive the following error messages:

System Message 10232
Assertion failure!
File: sqlapi.cpp
Line: 10364
Expression: tmpDidErrOccur == noError
Hit OK to stop program, and report the error to Microsoft Support, noting the failed expression, file name and line number.
Programming Bulletproof Error 10262
Invalid cursor value passed to sfetch1(). Please make sure cursor value is greater than 0. Also verify that this cursor has been passed to sql().Assertion Failed: abort=Quit, Retry=Debug, Ignore=Continue

Cause

There are two System Databases that are both linked to the same Application Database.

Resolution

To fix this issue, follow these steps:

  1. Open SQL Server Management Studio.

  2. Execute the following select statement against each Microsoft Dynamics SL System Database:

    select databasename from domain
    
  3. If you find the same Microsoft Dynamics SL Application database name listed in more than one system database, it will cause the errors. Update or remove the duplicated record.

  4. Open Microsoft Dynamics SL Database Maintenance.

  5. Connect to the server.

  6. On the update databases tab, run the Synchronize All Ownership and Security process.