Troubleshooting Client for NFS
Applies To: Windows Server 2003 R2
What problem are you having?
Issues
I need Client for NFS to only use “privileged” ports.
Cause
Some Network File System (NFS) servers have a concept of “privileged” ports (meaning ports numbered lower than 1024), and will not accept client connections from ports above that range.
Solution
Log onto computers running Client for NFS and set the following registry key to 1 and restart Client for NFS:
HKLM\Software\Microsoft\Client for NFS\CurrentVersion\default
DWORD “UseReservedPorts”
An error occurred while trying to communicate with the Client for NFS service.
Cause
The Client for NFS service is not started, cannot contact Active Directory or the User Name Mapping server, or is running with credentials that are mapped incorrectly.
Solution
In Microsoft Services for Network File System, you can ensure that the service is started by right-clicking Client for NFS, and then clicking Start. In Microsoft Services for Network File System, ensure that the name of the correct Active Directory domain or User Name Mapping server is specified. Check with the administrator of the Active Directory or the User Name Mapping server to ensure that your Windows user account is properly mapped to your UNIX user account.
System error 1722 has occurred. The remote procedure call (RPC) server is unavailable.
Cause
The Client for NFS service is not started.
Solution
In Microsoft Services for Network File System, right-click Client for NFS, and then click Start.
An attempt to mount a shared directory produces a network error 67, the network name was not found.
Cause
The directory is not shared, or the server is unable to resolve the client name.
Solution
Use showmount –eserver to display the names of shared directories on the server. If this fails with a remote procedure call (RPC) time-out, contact the administrator of the Network File System (NFS) server to ensure that the NFS and portmap services are started on the server. Ensure that the Internet Protocol (IP) address of the client is specified in either the server /etc/hosts file, or in the DNS database, as appropriate.
I received the message RPC: Timed out or RPC: Port mapper failure – RPC: Timed out.
Cause
Either the port mapper or Network File System (NFS) server daemons are not running on the server, or Client for NFS performance settings need to be adjusted.
Solution
Ensure that the services are started. If the port mapper and NFS server daemons are running on the server, in Microsoft Services for Network File System, click Client for NFS, and then increase the maximum number of retries and the interval between retries.
A file I created on a mounted Network File System (NFS) drive is shown as having been created by nobody:nogroup or by –2:–1, or the user identifier (UID) is a very large number (2**32-2).
Cause
Your Windows user name is not properly mapped in Active Directory or User Name Mapping.
Solution
Use the server running User Name Mapping for your Windows user account that is not properly mapped. In Microsoft Services for NFS, check to ensure that the name of the correct Active Directory domain or User Name Mapping server is specified. Check with the administrator of the Active Directory or User Name Mapping server to ensure that your Windows user account is properly mapped to your UNIX user account.
When I attempt to map a network drive, I am asked for a user name and password, and then the attempt to map the drive fails even though I supply valid credentials.
Cause
Either an Active Directory domain or a User Name Mapping server has not been designated for use by Microsoft Services for NFS.
Solution
Specify the correct Active Directory domain or User Name Mapping server. For more information, see Specifying how Client for NFS retrieves UNIX-style identity data.
I cannot access files on a mapped network drive.
Cause
Neither an Active Directory domain nor a User Name Mapping server has been designated for use by Microsoft Services for NFS.
Solution
Specify the correct Active Directory domain or User Name Mapping server. For more information, see Specifying how Client for NFS retrieves UNIX-style identity data.
I cannot mount a shared root directory (/) on a UNIX computer.
Cause
When a root directory (/) on a UNIX computer is shared, Client for NFS cannot mount it by using the standard path syntax (net use * \\server\ or net use server:/).
Solution
To mount the root directory, enter this command:
net use * \\server\!
The share name must be an exclamation mark (!).
MS-DOS-based or earlier Windows-based applications cannot access files on NFS, or a message appears indicating that a 16-bit application cannot be run.
Cause
By default, Client for NFS does not convert UNIX long file names to the MS-DOS–style 8.3 format.
Solution
Use Registry Editor (Regedit.exe) to ensure that the following entry is set to a value of 1 (the default):
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Client for NFS\CurrentVersion\Users\Default\Defaults\8.3Format
This causes Client for NFS to convert all UNIX file names to the 8.3 format required by MS-DOS-based applications and by applications designed to run with Windows 3.x and earlier. Setting this entry to a value of 0 improves Client for NFS performance somewhat because Client for NFS does not convert file names.
Warning
Incorrectly editing the registry may severely damage your system. Before making changes to the registry, you should back up any valued data on the computer.
I received a delayed write error message.
Cause
Either the NFS server is not responding or the Client for NFS performance options are not properly adjusted.
Solution
Use the showmount –eserver command to determine whether the NFS server is running properly.
Attempting to mount with the net use command produces the error message: 1788: The trust relationship between the primary domain and the trusted domain failed.
Cause
You are attempting to access a computer in an untrusted domain, and either Client for NFS has not started on your computer or the share is not available from the NFS server.
Solution
In Microsoft Services for Network File System, right-click Client for NFS, and then click Start. Use showmount –eserver to display the names of shared directories on the server. If this fails with an RPC time-out, contact the administrator of the NFS server to ensure that the NFS and portmap services are started on the server and that the shared directory is available.
Even after changing the default permissions for new files, new files on a mount are still created with the previous permissions.
Cause
This is by design. New default permissions are only applied to new mounts.
Solution
Unmount and then remount the shared directory.
After restarting the computer, the mount parameters of a persistent mount are changed.
Cause
You used the net use command to mount the directory.
Solution
Use the mount utility to mount the directory.
Authenticated users cannot access NFS resources, or all NFS shares are accessed as Anonymous.
Cause
User Name Mapping is not properly configured to work with this computer.
Solution
Ensure that the .maphosts file on the computer running User Name Mapping specifies the names or Internet Protocol (IP) addresses of computers that can map user accounts by using User Name Mapping. For more information, see Securing access to the User Name Mapping server. If users cannot access NFS resources intermittently and configuring the .maphosts file does not solve the problem, it could be that too many client computers are trying to access User Name Mapping simultaneously. See "Error message: Unable to perform the requested operation as the mapping service cannot be contacted" in Troubleshooting User Name Mapping.