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"Access Denied" error when trying to access a shared folder

Symptoms

Consider the following scenario:

  • You have a SharePoint or OneDrive site.
  • The site has the Limited-access user permission lockdown mode site collection feature activated.
  • You share a specific folder with another user.
  • The other user tries to access the shared folder.

In this scanario, the other user receives one of the following error messages:

  • Access Denied
  • You need permission to access this resource

Cause

When you share a folder with a user who can't access the parent folder or site, SharePoint assigns the user Limited Access to the parent items. Specifically, SharePoint allows the user to access the folder without obtaining permission to access the parent folder and other items (other than limited access). However, when Limited-access user permission lockdown mode is enabled, the user doesn't have access to the folder because the necessary limited access permission on other items no longer works correctly.

Workaround

To work around this issue, use one of the following options, as appropriate for your situation:

  • Share individual files but not folders.

  • Share a whole site collection or subsite.

  • If your site doesn't require Limited-access user permission lockdown mode, disable this site collection feature.

    Note: Other features, such as publishing, might require this feature to work correctly.