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"403 Forbidden" error on OneDrive or SharePoint

Symptoms

When you try to access a file from a OneDrive or SharePoint website that another user shares with you, you receive the following error message:

Error: 403 Forbidden

Cause

The “403 Forbidden” error might occur because of one of the following conditions:

  • Your browser cache has to be cleared.

  • Your permissions to the file haven’t replicated correctly on the server.

  • Your OneDrive site is locked.

  • An issue affects your organization’s SharePoint Online services.

Resolution

Use the available privacy mode of your web browser when you sign in to Microsoft 365. For example, use InPrivate mode in Microsoft Edge, or Incognito mode in Google Chrome. Then, try to access the file. To learn how to browse through an InPrivate window, see Microsoft Edge. To learn how to browse through an Incognito window, see Google Chrome.

If you can access the file while you browse in a privacy mode, clear your browser cache. To learn how to clear the browser cache, see Edge or Chrome.

If that doesn’t solve the problem, contact the SharePoint or OneDrive administrator for your organization. If you don't knows who that is, see How do I find my Microsoft 365 admin?.

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Actions for administrators

If clearing the cache doesn’t solve the problem, try the following methods.

Reshare the file

It’s possible that permissions for the file haven’t replicated correctly or completely. Ask the user to wait 30 minutes before trying to access the file again. If the error still occurs after 30 minutes, try the steps that are listed under "When accessing a SharePoint site" or "When accessing a OneDrive site" in "Access Denied", "You need permission to access this site", or "User not found in the directory" errors in SharePoint Online and OneDrive for Business.

Check whether the OneDrive site is locked

It's possible that the user's OneDrive site is in a locked "NoAccess" state. As a global or SharePoint admin in Microsoft 365, you can unlock the site by using PowerShell or running a Microsoft 365 Diagnostic. For more information, see SharePoint or OneDrive read-only error messages.

Check the service health

As an admin, go to the Service Health page (Health > Service health) in the Microsoft 365 Admin Center. Check for any advisories or incidents that might be occurring. If there are no advisories or incidents occurring for SharePoint Online, you can select Report an issue if it’s available to you, or open a new service request with Microsoft 365 technical support.

Provision the OneDrive site

Error 403 can occur if the user is trying to access a OneDrive site that is not provisioned. Have the user try to navigate to the OneDrive tile from the Microsoft 365 portal.

If that doesn't work, provision the site by using the Request-SPOPersonalSite cmdlet.

Access another user's OneDrive data

If the user is trying to access the OneDrive data of another user, such as a former employee, you can grant permissions to the user by following the steps in Step 4 - Give another employee access to OneDrive and Outlook data.