Note
Access to this page requires authorization. You can try signing in or changing directories.
Access to this page requires authorization. You can try changing directories.
Symptoms
When existing users in an organization try to access a SharePoint Online resource, but they don't have permissions to the resource, they receive one of the following error messages:
- Sorry, this site hasn't been shared with you.
- Error: Access Denied.
- You can't access this item.
- You don't have permission to access this item.
However, users don't have an option to request access to the resource.
Cause
The errors occur because access requests aren't enabled for the site collection that's associated with the resource.
Resolution
To resolve the errors, enable access requests for the affected site collection. You must be a site collection administrator to enable this feature.
As a site collection administrator, use the following steps to enable access requests:
On the affected SharePoint Online site collection, select Settings > Site Settings.
On the Site Settings page, under Users and Permissions, select Site permissions.
Select Access Request Settings.
Select the Allow Access Requests check box.
In the Send all requests for access to the following email address, enter the email address of the user acount that approves access requests, and then select OK.
Now users who don't have permission to a SharePoint Online resource are directed to a page where they can request access. Requests for access are sent to the email address that's specified in step 5.