"This item might not exist" error when accessing OneDrive

Symptoms

When you try to access a Microsoft OneDrive webpage, you receive the following error message:

This item might not exist or is no longer available.

This item might have been deleted, expired, or you might not have permission to view it. Contact the owner of this item for more information.

Screenshot of This item might not exist error.

Cause

The default document library name on the OneDrive site was changed from ”Documents” to some other name.

Resolution

To resolve this issue, you must rename the document library to “Documents” by using one of the following methods.

Note

You must have administrative permissions to make these changes, or contact your administrator to make these changes.

Method 1: Use the Microsoft Admin site

Note

This diagnostic isn't available for the GCC High or DoD environments, or for Microsoft 365 operated by 21Vianet.

  1. Select Run Tests below, which will populate the diagnostic in the Microsoft 365 Admin Center.

  2. In the Run diagnostics section, enter a value for User Principal Name (UPN) for the user in question, and then select Run Tests.

    Screenshot shows the Run Diagnostics section.

  3. If the test results indicate that the default document library name was changed, select the checkbox, and then select Update Settings.

    Screenshot shows the Update Settings button.

Method 2: Use SharePoint Designer

  1. In SharePoint Designer, open the OneDrive site.

  2. Navigate to All Files.

  3. Right-click the library, select Rename, and then rename the library to Documents.

    Animated GIF showing how to rename Documents library.

Note

We recommend that you do not use SharePoint Designer to make customizations on OneDrive sites.

More information

Still need help? Go to Microsoft Community.