Note
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Access to this page requires authorization. You can try changing directories.
Symptoms
When you create an alert in a SharePoint Online list or library, you receive the following error message:
Sorry, something went wrong. You do not have an e-mail address. Alert has been created successfully but you will not receive notifications until valid e-mail or mobile address has been provided in your profile.
Cause
This error occurs because there's no email address associated with the SharePoint Online user profile. The error occurs most frequently when the user doesn't have an Exchange Online license assigned to their account.
Resolution
To resolve this issue, configure SharePoint Online to enable users to configure their email address within their My Site profile and replicate the changes to the sites. As a SharePoint administrator, follow these steps:
Browse to the Microsoft 365 portal at https://portal.office.com.
Select the Admin link at the top of the window, and then select SharePoint.
In the SharePoint admin center, select User profiles.
In the People section, select Manage User Properties.
Locate the Work email property name and rest the mouse pointer over the property.
Select the drop-down arrow, and then select Edit.
In the Edit Settings section, select the option next to the Allow users to edit values for this property setting.
In the Policy Settings section, select the check box next to Replicable.
Note
The Replicable setting is necessary to make sure that the properties are propagated to all site collections within the organization.
Scroll to the bottom of the page, and then select OK.
Users can now edit their My Site profile to configure the Work email field as needed. SharePoint alerts for the user are sent to the address in this field.
Still need help? Go to SharePoint Community.