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You can't sync a shared folder that's set as a shortcut in OneDrive sync app

Symptoms

You create a shortcut to a folder that's stored in a SharePoint Online document library, and then you add the shortcut to OneDrive. When you try to sync the SharePoint Online document library with the Microsoft OneDrive sync app, the sync stops working, and you receive the following error message:

Sorry, we can't sync this folder. You're already syncing a shortcut to a folder from this shared library.

Cause

This behavior is by design. You can't sync a document library that's already set as a shortcut in OneDrive. Similarly, you can't use the Add shortcut to My files option if the document library is already synced.

Note: For a SharePoint document library, you can't use both the Sync and Add shortcut to My files features.

Resolution

To fix this issue, use one of the following methods to remove the shortcut.

Method 1: Remove the shortcut from the OneDrive folder

  1. Open the OneDrive folder on your device.
  2. Find the shortcut folder that has a small link icon ( ).
  3. Right-click the shortcut folder, and select Delete.

If you can't remove the shortcut folder, pause syncing in the OneDrive sync app, and then try again to delete the shortcut.

Method 2: Remove the shortcut from the OneDrive site

  1. Sign in to your Microsoft 365 account, and then select OneDrive from the app launcher ( ). Or, open your OneDrive site URL directly.
  2. In the upper-left corner, select My files.
  3. Find the shortcut folder that has a small link icon ( ).
  4. Right-click the folder, or select the three dots icon ( ) that's next to the folder, and then select Remove.

If you can't remove the shortcut, pause syncing in the OneDrive sync app, and then try again to delete the shortcut.