Note
Access to this page requires authorization. You can try signing in or changing directories.
Access to this page requires authorization. You can try changing directories.
Symptoms
You can't sign in to Microsoft OneDrive, and you receive the following error message:
Sorry, there was a problem with OneDrive. Please restart your computer. If the problem persists, please reinstall OneDrive. (Error Code: 0x8004def4)
Cause
This issue might occur for different reasons. This includes conditions such as a folder name conflict, or situations such as synchronizing an existing OneNote notebook with the OneDrive sync app without going through the OneNote application.
Resolution
To fix issues that are caused by folder name conflicts or OneNote notebook synchronization, use Microsoft Support and Recovery Assistant.
Download and install Microsoft 365 Support and Recovery Assistant.
Select OneDrive for Business > Next.
Select I need help syncing my OneDrive files, and then select Next.
If the Assistant can't resolve the issue, the cause might be something other than sync conflicts. In this case, try to Reset OneDrive. If the issue persists, uninstall OneDrive, and then reinstall it.