Note
Access to this page requires authorization. You can try signing in or changing directories.
Access to this page requires authorization. You can try changing directories.
Symptoms
When you try to sign in to Microsoft OneDrive, you can't sign in, and you receive error code 0x8004def7.
Cause
This problem has the following possible causes:
- Your OneDrive storage exceeded its storage limit.
- Your account was suspended.
- The OneDrive sync app has configuration issues.
Resolution
To resolve this problem, try the following methods. If one method doesn't work, try the next method.
Check your OneDrive storage to determine how much space you've used. If you have exceeded or are getting close to the storage limit, delete files or folders in OneDrive to free up space.
Unlink and relink OneDrive. This method can resolve existing OneDrive sync app configuration issues.
Reset OneDrive. This method resets all OneDrive settings and sometimes resolves sync issues. OneDrive will run a full sync after the reset.
If you have a Skype, Xbox, Hotmail, or Outlook.com account, you also have a OneDrive account. Even if you access other Microsoft services, your OneDrive account will be frozen if you haven't accessed your OneDrive account in 12 months, or if you exceed your storage limit. To determine why your account is frozen and learn how to unfreeze your account, see What does it mean when your OneDrive account is frozen?