Note
Access to this page requires authorization. You can try signing in or changing directories.
Access to this page requires authorization. You can try changing directories.
This article explains how to resolve an intermittent test failure that causes a protocol violation error.
Symptoms
An Application Insights availability monitoring intermittent test fails and generates a protocol violation error.
Cause
The error, "protocol violation...CR must be followed by LF," indicates an issue with the server or its dependencies. This error occurs if malformed headers are set in the response. It can be caused by load balancers or CDNs. Specifically, some headers might not be using CRLF to indicate end of line. This violates the HTTP specification. Therefore, the test fails validation at the .NET WebRequest level.
Solution
Inspect the response, and look for headers that might be violating this HTTP specification.
Note
The URL might not fail in web browsers that have a relaxed validation of HTTP headers. For a detailed explanation of this issue, see the blog article, A tale of debugging - the LinkedIn API, .NET and HTTP protocol violations.
Next steps
Use TrackAvailability to submit custom availability tests.
Learn about URL ping tests.
Contact us for help
If you have questions or need help, create a support request, or ask Azure community support. You can also submit product feedback to Azure feedback community.