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Applies to: ✔️ SQL Server VMs
This article discusses how to troubleshoot an issue that prevents you from extending the volume on a Microsoft SQL Server-based standalone server virtual machine (VM) that's deployed from Azure Marketplace.
Symptoms
You can't manually configure the volume of your SQL Server standalone server VM that's deployed from Azure Marketplace.
Cause
A storage pool that has DATA and LOG volumes was already created when the SQL Server-based server was deployed.
Solution
You can extend these volumes from the Azure portal through the SQL Server configuration menu. Follow these steps:
Sign in to the Azure portal, and then select your VM.
In the left pane of the Virtual Machine Overview tab, select SQL Server configuration under Settings.
Select Manage SQL virtual machine.
In the left pane, select Storage Configuration under Settings.
Select Configure under Configure drive, and then extend the Data, Log, and temporary db (database) volume.
Select the disk size, enter the number of new disks that have to be added to the existing storage pool, and then select Apply.
Important
Extending the disk volume will add disks on the VM. It will also extend the storage pool (and the volume that's created from that storage pool) without any user input from within the VM.
Extending the disk volume won't extend the existing disks. Therefore, it's important to add the disks carefully based on the VM size requirements so that you don't exceed the total number of disks that can be added. If you exhaust the total number of data disks, you'll have to upgrade the VM size to extend the volume and storage pool.
Contact us for help
If you have questions, you can ask Azure community support. You can also submit product feedback to Azure feedback community.