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Applies to: ✔️ Windows VMs
This article provides steps to resolve issues where the guest operating system (guest OS) is stuck waiting for Local Session Manager to finish processing while it boots an Azure virtual machine (VM).
Symptoms
When you use boot diagnostics to view a screenshot of the VM's output, you'll see that the screenshot displays a prompt with a "Please wait for the Local Session Manager" message.
Cause
There could be multiple reasons for a VM to be stuck waiting for Local Session Manager. If this issue persists, you need to collect a memory dump for analysis.
Solution
Tip
If you have a recent backup of the VM, you may try restoring the VM from the backup to fix the boot problem.
In some cases, simply waiting for the process to finish will resolve the issue. If your VM doesn't respond and remains on the wait screen for over an hour, you should collect a memory dump and then contact Microsoft support.
Attach the OS disk to a new repair VM
- To prepare a repair VM, follow steps 1-3 of the VM repair commands.
- Connect to the repair VM by using Remote Desktop Connection.
Locate the dump file and submit a support ticket
- On the repair VM, go to the Windows folder on the attached OS disk. For example, if the drive letter that's assigned to the attached OS disk is labeled F, go to
F:\Windows
. - Look for the memory.dmp file, and then submit a support ticket with the memory dump file attached.
- If you're having trouble locating the memory.dmp file, follow the guide to generate a crash dump file using non-maskable interrupt (NMI) calls.
For more information about NMI calls, see the NMI calls in Azure Serial Console user guide.
Next steps
Contact us for help
If you have questions or need help, create a support request, or ask Azure community support. You can also submit product feedback to Azure feedback community.