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Applies to: Visual Studio 2022
Symptoms
After you successfully create a minimal layout and test it on a system, an error message like the following one is displayed:
Snippet from the log:
[3004:0006][<DateTime>] Unable to select suitable download engine.
[3004:0006][<DateTime>] Unable to get download engine: Can not download. No suitable download engine found.
[3004:0006][<DateTime>] Error 0x80131500: Unable to download the channel manifest from https://aka.ms/vs/17/release/channel. at Microsoft.VisualStudio.Setup.ChannelManager.<AddAsync>d__43.MoveNext()
[3004:0006][<DateTime>] Error 0x80131500: Failed to initialize the app in AppInitializerService.InitializeChannelsAsync: Microsoft.VisualStudio.Setup.ChannelManifestDownloadException
Cause
The issue can occur if the upgrade is performed from a new profile, or the content under the %localappdata%\Microsoft\VisualStudio folder is missing or corrupt. This folder hosts the channel manifest file, which contains details about the product and its upgrades.
Ideally, this behavior shouldn't occur when installing and updating Visual Studio using the same user account. Visual Studio creates the _channels folder during the initial installation under C:\ProgramData\Microsoft\VisualStudio\Packages and %localappdata%\Microsoft\VisualStudio\Packages. During the update process, Visual Studio compares the catalog and channel manifest files from these locations to ensure a smooth update.
Resolution
To resolve this issue, follow these steps:
- Copy the _channels folder located under C:\ProgramData\Microsoft\VisualStudio\Packages.
- Create a new folder named Packages under the %localappdata%\Microsoft\VisualStudio directory.
- Paste the _channels folder into the newly created Packages folder.
- Try running the update process again.