Required variables and actions are missing during transfers from Copilot Studio agents to customer service representatives

This article provides a resolution for the error that occurs when you configure the handoff between a Copilot Studio agent and the voice workstream in Omnichannel for Customer Service.

Symptoms

When you configure the handoff between a Copilot Studio agent and the Omnichannel voice workstream, an error message that resembles the following is displayed on the Copilot Studio dashboard.

Your bot doesn't have access to all the required variables and actions. Ask your admin about installing the Omnichannel package or follow this step-by-step walkthrough.

Cause

The configuration is missing extensions that allow the agent to access the variables and actions it needs to complete the transfers.

Resolution

Ensure that the following extensions are installed. These extensions provide out-of-the-box actions or variables in the Copilot Studio authoring canvas that make the authoring experience easier for the agent author.