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This article provides a resolution for the issue that you can't use Microsoft Dynamics 365 App for Outlook due to the "You don't have the required role or privilege to complete this action" error.
Applies to: Dynamics 365 App for Outlook
Original KB number: 4557523, 4555675
Symptoms
When you try to use Dynamics 365 App for Outlook, you receive the following error message:
You don't have the required role or privilege to complete this action. Please contact your administrator to get necessary access.
Cause
This error occurs when a user without the System Administrator role tries to open Dynamics 365 App for Outlook and their mailbox is set up with a Dynamics 365 sandbox environment with administration mode enabled. Only users with the System Administrator role can access the environment when administration mode is enabled.
Resolution
To solve this issue, you can disable administration mode or take the following steps to ensure the user is assigned the appropriate security role when administration mode is enabled:
- Access Microsoft Dynamics 365 as a user with the System Administrator role.
- Navigate to Settings and then select Security.
- Select Users.
- Select your user and select Manage Roles.
- Select the Dynamics 365 App for Outlook User security role and then select OK.
- Try to open Dynamics 365 App for Outlook again.