Payroll employee self service timecard approvals aren't going to correct approver in Microsoft Dynamics GP

This article provides a solution to an issue where payroll timecard approvals aren't going to correct approver in Microsoft Dynamics GP.

Applies to:   Microsoft Dynamics GP
Original KB number:   4132654

Symptoms

Payroll employee self service timecard approvals aren't going to correct approver in Microsoft Dynamics GP, or skipping direct managers.

Cause

Workflow will route to the manager defined in Active Directory, not the supervisor ID assigned to the Employee in Dynamics GP on the Employee Maintenance card.

Note

If someone else resubmits a workflow, the system would consider the Windows user sign-in on that machine as the requestor.

If the system is unable to find the approver, it will be routed to the workflow manager by default.

Resolution

Workflow is driven by Active Directory, the supervisor field in Payroll isn't used in this process. The manager that will be used for workflow is the manager listed in Active Directory under the Organization tab of the user, when you select Properties. You may need to add the managers in Active Directory, not on the supervisor of the employee.

Employee to Direct Manager Workflow: How it works is a blog article that explains how this process works as well.