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This article describes a problem in which users experiences an "AADSTS500011" error when they try to sign in to Microsoft Entra ID.
Symptoms
When users try to sign in to an application that uses Microsoft Entra ID authentication, they receive the following error message:
AADSTS500011 - The resource principal named [resource URL] was not found in the tenant named [tenant ID]
Cause
This issue occurs if the resource principal (the application or service) is not found in the tenant. This issue occurs if:
- The resource application isn't provisioned by the administrator in the tenant.
- The resource application isn't consented to by any user in the tenant.
- The resource URL is not configured correctly.
- The tenant ID is not correct.
Resolution
To resolve this issue, follow these steps:
Verify resource application provisioning:
- Make sure that the application (resource principal) is registered correctly in your Microsoft Entra ID tenant.
- Go to the Azure portal, and navigate to Microsoft Entra ID > Enterprise applications.
- Check whether the application is listed and correctly configured.
Consent to application:
- Make sure that the resource application has been consented to by an administrator or a user in the tenant.
- Go to the Azure portal, and navigate to Microsoft Entra > Enterprise applications.
- Find the application, and make sure that it has the necessary permissions and consent.
Check resource URL:
- Verify that the resource URL that appears in the error message matches the resource application that you provisioned in your tenant ID.
- Make sure that the authentication request is sent by using the correct resource URL.
Check tenant ID:
- Verify that the tenant ID that appears in the error message is the same as your tenant ID.
- Make sure that the authentication request is sent to the correct Microsoft Entra ID tenant.
More information
For a full list of authentication and authorization error codes, see Microsoft Entra authentication and authorization error codes.
To investigate individual errors, go to https://login.microsoftonline.com/error.
Contact us for help
If you have questions or need help, create a support request, or ask Azure community support. You can also submit product feedback to Azure feedback community.