Updates aren't downloaded when you run an ADR
Applies to: Configuration Manager current branch, versions 1910, 2002, 2006, and 2010
Symptoms
You use an automatic deployment rule (ADR) to deploy software updates. However, the updates aren't downloaded when you run the ADR. Additionally, you receive the following error messages in the Patchdownloader.log file:
Failed to create temp file with GetTempFileName() at temp location C:\Windows\TEMP\, error 80 Software Updates Patch Downloader
ERROR: DownloadUpdateContent() failed with hr=0x80070050 Software Updates Patch Downloader
When this problem occurs, the c:\windows\temp directory contains more than 65,535 0-byte .tmp files.
Cause
This problem is caused by an issue in the following Microsoft Endpoint Configuration Manager updates:
- Office updates fail to download in Configuration Manager current branch, version 1910
- Office updates fail to download in Configuration Manager current branch, version 2002
- Update Rollup for Microsoft Endpoint Configuration Manager version 2006
The .tmp files are created but not removed. This problem occurs if the number of .tmp files exceeds 65,535.
Resolution
This problem is fixed in Update Rollup for Microsoft Endpoint Configuration Manager current branch, version 2010.
The fix will be included in Configuration Manager current branch, version 2103.
To fix the problem in Configuration Manager current branch, versions 1910, 2002, and 2006, delete the .tmp files in c:\windows\temp, and then rerun the ADR.
Feedback
https://aka.ms/ContentUserFeedback.
Coming soon: Throughout 2024 we will be phasing out GitHub Issues as the feedback mechanism for content and replacing it with a new feedback system. For more information see:Submit and view feedback for