Error 0x800f0831 when you install an update

This article fixes an issue in which you receive error 0x800f0831 when you install a cumulative update.

Original product version:   Configuration Manager (current branch), Windows Server Update Services
Original KB number:   4477073

Symptom

When you try to install a Windows update, especially a cumulative update, you receive the following error message in WindowsUpdate.log:

FATAL: CBS called Error with 0x800f0831

This issue is more likely to occur when there's no access to Microsoft Update.

Additionally, you receive error messages that resemble the following in CBS.log:

Store corruption, manifest missing for package: <Missing_Package>
Failed to resolve package <Missing_Package> [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Mark store corruption flag because of package: <Missing_Package> [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Failed to resolve package [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Failed to get next package to re-evaluate [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Failed to execute execution chain. [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Failed to process single phase execution. [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
WER: Generating failure report for package:<Failed_Package> status: 0x800f0831, failure source: Execute, start state: Staged, target state: Installed, client id: DISM Package Manager Provider

Note

<Failed_Package> represents the package that can't be installed. <Missing_Package> represents the package for which the manifest is missing.

Cause

This issue occurs because the update that can't be installed requires the manifest of a previous update package.

Resolution

To fix the issue, use one of the following methods.

Method 1: Repair the component store with DISM commands

To repair the component store using the DISM RestoreHealth command, follow these steps:

  1. Open an elevated command prompt and run these commands:

    DISM /ONLINE /CLEANUP-IMAGE /SCANHEALTH
    
    DISM /ONLINE /CLEANUP-IMAGE /CHECKHEALTH
    
    DISM /ONLINE /CLEANUP-IMAGE /RESTOREHEALTH
    
    Sfc /Scannow
    
  2. Restart the device.

Method 2: Manually repair with the payload of the partially installed component

  1. Go to Microsoft Update Catalog.
  2. In the Search box, enter the package ID of the <Missing_Package>.
  3. Find the update that applies to your operating system appropriately in the search results, and then select the Download button.
  4. In the Microsoft Update Catalog window, select the link of the file to download the update.
  5. Select Close after the download process is done. Then, you can find a folder that contains the update package in the location that you specified.
  6. Open the folder, and then double-click the update package to install the update.