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This article solves the connection failure that occurs when you try to integrate Microsoft Intune with Jamf Pro.
Symptoms
When you try to configure Microsoft Intune integration in Jamf Pro, you receive the following error message that indicates a connection failure:
Could not retrieve the access token for Microsoft Graph API. Check the configuration for Microsoft Intune Integration.
Cause
This issue occurs if the ports that are required for communication between Jamf Pro and Intune are blocked by your firewall or proxy server.
Solution
To fix the issue, make sure that the following TCP ports aren't blocked:
- Intune: 443
- macOS devices: 2195, 2196, and 5223
- Jamf Pro: 80 and 5223
More information
- Support Tip: Troubleshooting issues with macOS devices when using Jamf/Intune integration
- Network endpoints for Microsoft Intune - Apple device network information
- Network Ports Used by Jamf Pro
- TCP and UDP ports used by Apple software products
Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.
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