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Could not retrieve the access token for Microsoft Graph API when configuring Intune integration in Jamf Pro

This article solves the connection failure that occurs when you try to integrate Microsoft Intune with Jamf Pro.

Symptoms

When you try to configure Microsoft Intune integration in Jamf Pro, you receive the following error message that indicates a connection failure:

Could not retrieve the access token for Microsoft Graph API. Check the configuration for Microsoft Intune Integration.

Screenshot of the Jamf error.

Cause

This issue occurs if the ports that are required for communication between Jamf Pro and Intune are blocked by your firewall or proxy server.

Solution

To fix the issue, make sure that the following TCP ports aren't blocked:

  • Intune: 443
  • macOS devices: 2195, 2196, and 5223
  • Jamf Pro: 80 and 5223

More information

Third-party information disclaimer

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Third-party contact disclaimer

Microsoft provides third-party contact information to help you find additional information about this topic. This contact information may change without notice. Microsoft does not guarantee the accuracy of third-party contact information.