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Error code 80048539 occurs when trying to import a solution patch in Dynamics 365

This article provides a resolution for error code 80048539 that may occur when you try to import a solution patch in Microsoft Dynamics 365.

Applies to:   Microsoft Dynamics 365
Original KB number:   4471087

Symptoms

When you try to import a solution patch in Dynamics 365, you receive the following error message:

The import of solution: [solution patch name] failed.
Error code 80048539.

If you download the log file and open it in Excel, additional details similar to the following are displayed:

Failure 0x80048539
Solution manifest import: FAILURE: Patch version 1.0.1.0 is invalid for parent version 1.1.0.0

Cause

Error code 80048539 indicates an invalid patch is being imported.

This issue occurs because the version of the solution patch being imported is lower than the version of the installed solution. For example, a solution named "SolutionA" is already installed with version 1.1.0.0, but you try to import a patch with version 1.0.1.0.

Note

  • If you're using Power Apps to import your unmanaged solution update and receive the error, expand Advanced settings and select the Update (not recommended) option as a workaround.

  • Microsoft is aware of the issue and is working on a fix.

Resolution

To resolve this issue, verify that the solution patch version you're trying to import is higher than the version of the installed solution.

Follow these steps:

  1. Check the version of the solution currently installed in Dynamics 365.
  2. Confirm that the version of the solution patch you're trying to import is higher than the version of the installed solution.
  3. If necessary, update the version number of the solution patch and retry the import.