A failed license check on a desktop flow run

This article provides a resolution for the issue where you receive a license check error code when you trigger a desktop flow run in Power Automate for desktop.

Applies to:   Power Automate for desktop

Symptoms

If you trigger a desktop flow run using the Dataverse Web API RunDesktopFlow Action, you receive a JSON output that contains a licenseCheck object:

        {
            "licenseCheck": {
                "code": "ValidLicenseCoverage",
                "message": "Valid License Coverage"
            }
        }

If the licenseCheck result is valid, the code attribute shows ValidLicenseCoverage. Any other code informs you of a missing licensing component (license, add-on, or both).

Prerequisites

  • To run a desktop flow in attended mode, the desktop flow connection owner requires a "Power Automate Premium" user license.
  • To run a desktop flow in unattended mode, the target machine requires an "Unattended RPA add-on" or a "Power Automate Process" license.

For more information, see Types of Power Automate licenses.

Cause

If the licenseCheck result is invalid, the message attribute shows the missing licensing components. For more information, see the below table.

Code Message
ValidLicenseCoverage Valid License Coverage
LicensingCheckFailed Unable to perform licensing checks for this Desktop Flow
AttendedNoLicense Invalid License Coverage. Running this desktop flow in attended mode requires a "Power Automate Premium" user license.
UnattendedNoAddon Invalid License Coverage. Running this desktop flow in unattended mode requires an "Unattended RPA add-on" or a "Power Automate Process" license.

Resolution

To solve this issue:

  • If the "Power Automate Premium" user license is missing, contact your Microsoft 365 administrator to get this license assigned to the user owning the desktop flow connection.
  • If the "Unattended RPA add-on" or "Power Automate Process" license is missing, ask your Power Platform administrator to assign one to your environment from the Power Platform admin center.

Note

A failed license check (if it doesn't block the desktop flow run immediately) can mean that the cloud flow triggering the desktop flow run will soon be suspended for licensing reasons. Check the cloud flow in question to get more information.