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RDP automation fails to connect to a machine through CyberArk

This article helps you resolve an issue in which you can't connect to a machine through CyberArk when you use Remote Desktop Protocol (RDP) automation in Microsoft Power Automate for desktop.

Symptoms

When you execute an RDP automation and it attempts to connect to a machine through CyberArk, the Power Automate agent for virtual desktops doesn't establish communication with Power Automate for desktop, and you receive the following error message:

A device attached to the system is not functioning.

The error message that you receive when you try to connect through CyberArk.

However, when you connect directly to the machine by using RDP without CyberArk, the connection works as expected, and Power Automate for desktop successfully communicates with the agent.

Cause

CyberArk creates a nested remote connection path. This condition interferes with the agent-to-desktop communication that's required for UI and browser automation. Power Automate for desktop doesn't support nested remote connections.

Solution

To resolve this issue:

  • Use a direct RDP connection to the target machine instead of connecting through CyberArk.
  • Make sure that the Power Automate agent for virtual desktops is running and correctly registered on the machine.

Third-party information disclaimer

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.