Note
Access to this page requires authorization. You can try signing in or changing directories.
Access to this page requires authorization. You can try changing directories.
For a flow, sometimes you can't find the trigger or run history on the Run history page or the flow's Details page in Power Automate.
Applies to: Power Automate
Original KB number: 4538672
Symptoms
You can't see your Power Automate flow on the Run history page or the flow's Details page.
Cause
By default, flow run data is stored for 28 days. If you ran your flow over 28 days ago, it will no longer be shown on the flow's Run history page.
Resolution
If it's been over 28 days since you ran the flow, run it again so that the flow run data appears on the Run history page.
To maintain a flow run history for over 28 days, you need to manually capture the run history before it's deleted.
Tip
With the Cloud flow run history in Dataverse feature, administrators can manage or reduce the number of days for which the flow runs are retained in the Power Platform admin center. For more information, see Set FlowRun time to live in Power Platform admin center.