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"The user has not been assigned any license" error when accessing a process in the process mining capability

This article resolves a licensing error that occurs when you access a process in the process mining capability in Power Automate.

Applies to:   Power Automate Process Mining

Symptoms

When you access a process that is shared with a disabled user or a user without a license, the following error occurs:

Error loading users for this process: the user (id=<GUID>) has not been assigned any License. Please contact your system administrator to assign license to this user for the action to succeed.

Cause

The error occurs because the user that the process is shared with doesn't have an associated Power Automate license. In most cases, this issue occurs when the user the process is shared with already left the organization or has been disabled.

For more information about licensing and process mining capabilities offered with different licenses, see Overview of process mining and task mining in Power Automate.

Resolution 1: Delete the user from Dataverse

For more information, see Delete a user.

Resolution 2: Revoke sharing permissions from the user using a Power Automate flow

  1. In Power Automate, on the left pane, select My flows > + New flows > Instant cloud flow.

  2. Add a Perform an unbound action. Enter the following details:

    Action Name: Revoke Access

    Target: /msdyn_pminferredtasks(<PROCESS-ID>).

    The PROCESS-ID should be the process ID that needs to be revoked. The ID can be found in the URL.

    Revoke:

    {
      "systemuserid": "USER-ID",
      "@{string('@odata.type')}": "#Microsoft.Dynamics.CRM.systemuser"
    }
    

    The USER-ID should be the ID of the user that needs to be revoked. The ID can be found in the error message.