Note
Access to this page requires authorization. You can try signing in or changing directories.
Access to this page requires authorization. You can try changing directories.
This article provides a resolution for an error message that occurs when a user tries to create a record from Microsoft Copilot for Sales.
Requirement type | Description |
---|---|
Client app | Copilot for Sales Outlook add-in |
Platform | Web and desktop clients |
OS | Windows and Mac |
Deployment | User managed and admin managed |
CRM | Dynamics 365 and Salesforce |
Users | Users who try to create a CRM record from Copilot for Sales |
Symptoms
When a user tries to create a new record in your CRM from Copilot for Sales, the following error is displayed. It indicates that the record creation failed due to a duplicate detection rule in CRM.
This contact already exists. To create a duplicate contact, try adding it in Salesforce.
Cause
A duplicate detection rule in CRM is configured to prevent specific fields from having duplicate values across multiple records. When a user tries to create a record that contains a duplicate field from Copilot for Sales, the duplicate detection rule in CRM prevents the record from being created.
For example, if a duplicate detection rule is configured to prevent the creation of a record with the same email address as an existing record, the record creation fails if the new record's email address matches the existing record's email address.
Resolution
To resolve the error, use either of the following methods:
- Create the record again with a different value for the field that caused the error. For example, if an error occurs because the new record's email address matches an existing record's email address, re-create the record with a different email address.
- Ask your administrator to modify the duplicate detection rule in CRM to allow duplicate values for the field that caused the error.
For information about duplicate detection rules in CRM, see:
- Dynamics 365: Set up duplicate detection rules to keep your data clean
- Salesforce: Duplicate Rules
More information
If your issue is still unresolved, go to the Copilot for Sales - Microsoft Community Hub to engage with our experts.
Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.