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Errors that occur when enabling Salesforce with server-to-server flow

This article helps you troubleshoot errors that might occur when you try to enable Salesforce with a server-to-server flow in Microsoft Copilot for Sales.

Who is affected?

Requirement type Description
Client app Microsoft Teams
Platform Web and desktop clients
OS Windows and Mac
Deployment User managed and admin managed
CRM Salesforce
Users Administrators

Couldn't assign permission set because the integration user is inactive in Salesforce

Symptoms

When you try to enable Salesforce with a server-to-server flow, the following error message might occur:

Couldn't assign permission set because the integration user is inactive in Salesforce.

Cause

During the Salesforce server-to-server flow setup, a connected app is deployed to the Salesforce organization. The connected app is associated with an integration user that is created automatically. A permission set is then assigned to the integration user. The error occurs when the integration user is inactive in Salesforce. The permission set can't be assigned to an inactive user.

Resolution

To resolve this issue:

  1. In Salesforce, search for a user with the copilotforsalesintegrationuser prefix in the username.

  2. Confirm the user is active.

    • If inactive, set the user status to active.
    • If you can't activate the user, contact Microsoft support.

Couldn't create user because Salesforce integration license limit reached

Symptoms

When you try to enable Salesforce with a server-to-server flow, the following error message might occur:

Couldn't create user because Salesforce integration license limit reached.

Cause

During the Salesforce server-to-server flow setup, a connected app is deployed to the Salesforce organization. The connected app is associated with an integration user that is created automatically. A Salesforce Integration user license is assigned to this integration user. The error occurs when the maximum number of Salesforce Integration user licenses has already been reached.

Resolution

To resolve this issue, check if the maximum number of Salesforce Integration user licenses has been reached. If so, you need to reassign existing integration users to other licenses or purchase more licenses.

To check the number of integration user licenses available in your Salesforce organization:

  1. Sign in to Salesforce as an administrator.

  2. Go to Setup > Company Settings > Company Information.

  3. Under User Licenses, check the number of available Salesforce Integration licenses under the Remaining Licenses column. If the number is 0, you need to deactivate existing integration users or change their licenses to other types. You can also purchase more licenses.

Unexpected errors when enabling Salesforce with a server-to-server flow

Symptoms

When you try to enable Salesforce with a server-to-server flow, you might receive one of the following error messages:

  • Couldn't get deployment status due to incorrect ID format.

  • Couldn't find the connected app.

  • Couldn't get user license ID is missing to create connection user.

  • Couldn't fully remove connection data from Dataverse. Contact Sales support to request manual cleanup.

  • Couldn't complete the connected app or permission set deployment to Salesforce. Try again.

  • Couldn't complete the connected app deployment to Salesforce. Try again.

  • Couldn't complete the permission set deployment to Salesforce. Try again.

Cause

During the Salesforce server-to-server flow setup, a connected app is deployed to the Salesforce organization. The connected app is associated with an integration user that is created automatically. A permission set is then assigned to the integration user. In this process, some unexpected errors might occur.

Resolution

To resolve this issue, retry the operation. If the issue persists, gather the error details and contact Microsoft support.

No changes were made

Symptoms

When you try to enable Salesforce with a server-to-server flow, the following error message might occur:

No changes were made.

Cause

During the Salesforce server-to-server flow setup, a connected app is deployed to the Salesforce organization. The connected app is associated with an integration user that is created automatically. A permission set is then assigned to the integration user. The error occurs when the same permission set has already been assigned to the user.

Resolution

To resolve this issue, check for any manual changes to the connected app or profiles with the CopilotForSales prefix. If the changes were unintentional, revert them. Otherwise, retry the operation. If the issue continues, contact Microsoft support.

The profile name is already in use. Pick a different name or rename the existing profile in Salesforce

Symptoms

When you try to enable Salesforce with a server-to-server flow, the following error message might occur:

The profile name is already in use. Pick a different name or rename the existing profile in Salesforce.

Cause

During the Salesforce server-to-server flow setup, a profile named Copilot For Sales Integration Profile is created in the Salesforce organization. The error occurs when a profile with the same name already exists, preventing the creation process.

Resolution

To resolve this issue, check if a profile with the same name already exists in the Salesforce organization. If it was created before enabling the server-to-server flow, rename the existing profile and try again. If the profile wasn't created previously, contact Microsoft support.

More information

If your issue is still unresolved, go to the Copilot for Sales - Microsoft Community Hub to engage with our experts.

Third-party information disclaimer

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.