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"Required fields are missing" error when creating a contact or record from Copilot for Sales in Outlook

This article provides a resolution for the “Required fields are missing” error that occurs in the Microsoft Copilot for Sales panel in Outlook.

Who is affected?

Requirement type Description
Client app Copilot for Sales Outlook add-in
Platform Web and desktop clients
OS Windows and Mac
Deployment User managed and admin managed
CRM Salesforce
Users Users who don't have permission to view fields added in a Copilot for Sales form can't save, edit, or view the form

Symptoms

When a user tries to create a contact or record from the Copilot for Sales pane in Outlook, the following error message is displayed:

Required fields are missing

When you copy error details, you see the error code "SFRequiredFieldMissing".

Screenshot that shows the error that occurs when the required fields are missing.

Cause

The Salesforce object configuration was updated with a required field, but it wasn't added to the Copilot for Sales form through the admin settings in Microsoft Teams. Therefore, the required field is missing from the form, and the user can't save the record. When the user tries to save the record, the "Required field are missing" error is displayed.

Resolution 1: Update administrator settings in Microsoft Teams

  1. Access administrator settings in Microsoft Teams.
  2. Select Forms, and then select the object that displays the error.
  3. Select Refresh data.
  4. Select Add fields, find all the fields in the list that are marked as required in the CRM, and then add them to the form.
  5. Publish the changes.

Resolution 2: Change the required field property in Salesforce

  1. Sign in to Salesforce CRM as an administrator.

  2. Go to Setup > Object Manager, and select the object that displays the error.

  3. In the left pane, select Fields & Relationships, and then select the field that's mentioned in the error message.

  4. Select Edit, and then clear the Required checkbox under the General Options section.

    Note

    If you don't see the Required checkbox, it means that the field isn't a custom field. In this case, use Resolution 1: Update admin settings in Teams to resolve the issue.

Resolution 3: Delete the required field in Salesforce

  1. Sign in to Salesforce CRM as an administrator.

  2. Go to Setup > Object Manager, and then select the object that displays the error.

  3. In the left pane, select Fields & Relationships, and then find the field that's mentioned in the error message.

  4. If the field is a custom field, select the down arrow at the end of the row, and then select Delete.

    If the field isn't a custom field, use Resolution 1: Update admin settings in Teams to resolve the issue.

More information

If your issue is still unresolved, go to the Copilot for Sales - Microsoft Community Hub to engage with our experts.

Third-party information disclaimer

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.