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Can't sign in to Salesforce due to disabled connections

This article helps you troubleshoot and resolve an error that occurs in Microsoft Copilot for Sales when you can't sign in to Salesforce due to disabled connections.

Who is affected?

Requirement type Description
Client app Copilot for Sales Outlook add-in
Platform Web and desktop clients
OS Windows and Mac
Deployment User managed and admin managed
CRM Salesforce
Users All users

Symptoms

When you try to sign in to Salesforce from Copilot for Sales, the following error message is displayed:

Error from token exchange: The connection is disabled so it cannot be used.

Screenshot that shows the disabled Salesforce connection error.

Cause

The Salesforce connection is disabled in the msdyn_viva environment.

The Data Loss Prevention (DLP) policy is enabled in the tenant's msdyn_viva environment, thereby blocking the Salesforce connector. Therefore, existing connections to Salesforce have been disabled.

Resolution

  1. Sign out of Copilot for Sales and close the Copilot for Sales pane.
  2. Reopen the Copilot for Sales pane and sign in to Salesforce.

Note

If the issue isn't resolved, see Can't sign in to Salesforce due to blocked Salesforce connector to unblock the Salesforce connector in the DLP policy.

More information

If your issue is still unresolved, go to the Copilot for Sales - Microsoft Community Hub to engage with our experts.

Third-party information disclaimer

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.