Note
Access to this page requires authorization. You can try signing in or changing directories.
Access to this page requires authorization. You can try changing directories.
This article helps you troubleshoot and resolve sign-in issues when the Microsoft Power Platform app is blocked by an administrator in Microsoft Copilot for Sales.
Who is affected?
Requirement type | Description |
---|---|
Client app | Copilot for Sales Outlook add-in and Teams app |
Platform | Web and desktop clients |
OS | Windows and Mac |
Deployment | User managed and admin managed |
CRM | Salesforce |
Users | Users trying to authentication to their Salesforce instance |
Symptoms
When you try to sign in to Salesforce CRM from the Copilot for Sales add-in for Outlook, the following error message is displayed:
Failure passed to redirect url. error=OAUTH_APP_BLOCKED error_description=this app is blocked by admin
In Salesforce CRM, the Microsoft Power Platform app is shown as blocked on the Connected Apps OAuth Usage page.
Cause
The Microsoft Power Platform app in Salesforce CRM is blocked by an administrator.
Copilot for Sales connects to Salesforce CRM through the Microsoft Power Platform connected app. When the Microsoft Power Platform app is blocked by an administrator, the Salesforce authentication process fails with the error message.
Resolution
Ensure that the Microsoft Power Platform connected app isn't blocked in Salesforce CRM.
Sign in to Salesforce CRM as an administrator.
Go to Setup > Platform Tools > Apps > Connected Apps > Connected Apps OAuth Usage.
For the Microsoft Power Platform app, select Unblock.
The Microsoft Power Platform app disappears from the list, but it's unblocked.
After the first successful sign-in from the first user using Copilot for Sales, the Microsoft Power Platform app appears in the list again.
More information
If your issue is still unresolved, go to the Copilot for Sales - Microsoft Community Hub to engage with our experts.
Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.