Share via


Can't find the Viva Connections app in the Teams admin center

Symptoms

Your organization tries to set up and launch Viva Connections on desktop and mobile devices. However, Teams administrators can't find the Viva Connections app by using the following steps:

  1. Sign in to the Microsoft Teams admin center.
  2. Select Teams apps > Manage apps.
  3. Search for Viva Connections.

Cause

This issue may occur in the following situations:

  • The display name (short name) of the Viva Connections app was changed by using the Customize option.
  • There's an app provisioning issue that causes the app not to be found when searching.

Resolution

To fix this issue, Teams administrators should use the following steps:

  1. Open a new browser tab or window.

  2. Browse to the following URL:
    https://admin.teams.microsoft.com/policies/manage-apps/d2c6f111-ffad-42a0-b65e-ee00425598aa.

  3. Verify that this URL takes you to the Viva Connections app overview page. If not, check whether Viva Connections is included in your Microsoft subscription. For more information, see the full subscription comparison table.

    Note: A SharePoint license is required.

  4. On the Viva Connections app overview page, check the following settings in the Details section:

    • Short name: This is the display name of the Viva Connections app in your tenant. In the following example, it's Contoso App.

      Screenshot of the app details.

    • Short name from publisher: This value should be Viva Connections.

    • Publisher: This value should be Microsoft Corporation.

  5. In the Teams admin center, return to Teams apps > Manage apps.

  6. Search for the Viva Connections app by using the short name that's identified in step 4.

    Screenshot of the app search results.