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This article describes an issue where Active Directory Replications fail with error 1818: The remote procedure call was cancelled (RPC_S_CALL_CANCELLED).
Note
Home users: This article is only intended for technical support agents and IT professionals. If you're looking for help with a problem, ask the Microsoft Community.
Original KB number: 2694215
Symptoms
This article describes the symptoms, cause, and resolution steps when Active Directory replication fails with error 1818: The remote procedure call was cancelled (RPC_S_CALL_CANCELLED).
Possible formats for the error include:
Decimal Hex Symbolic Error string 1818 0x71a RPC_S_CALL_CANCELLED The remote procedure call was cancelled. The following events get logged
Event source Event ID Event string NTDS Replication 1232 Active Directory attempted to perform a remote procedure call (RPC) to the following server. The call timed out and was cancelled. NTDS Replication 1188 A thread in Active Directory is waiting for the completion of an RPC made to the following domain controller.
Domain controller:
b8b5a0e4-92d5-4a88-a601-61971d7033af._msdcs.Contoso.com
Operation:
get changes
Thread ID:
448
Timeout period (minutes):
5
Active Directory has attempted to cancel the call and recover this thread.
User Action
If this condition continues, restart the domain controller.
NTDS Replication1173 with error status 1818 Internal event: Active Directory has encountered the following exception and associated parameters. Exception: e0010002 Parameter: 0 Additional Data Error value: 1818 Internal ID: 5000ede NTDS Replication 1085 with error status 1818 Internal event: Active Directory could not synchronize the following directory partition with the domain controller at the following network address.
Directory partition: <NC>
Network address: <GUID-based DC name>
If this error continues, the Knowledge Consistency Checker (KCC) will reconfigure the replication links and bypass the domain controller.
User Action
Verify that the network address can be resolved with a DNS query.
Additional Data Error value: 1818 The remote procedure call was cancelled..
Repadmin /showreps
displays the following error messageDC=Contoso,DC=com
<Sitename>\<DCname> via RPC DC
DC object GUID: <GUID> Last attempt @ 2009-11-25 10:56:55 failed, result 1818 (0x71a): Can't retrieve message string 1818
(0x71a), error 1815. 823 consecutive failure(s). Last success @ (never).
Repadmin /showreps
from Domain Controller Name shows that it's failing to pull Domain NC from <SiteName> but can pull all other NCs===================
<Sitename>\<DC name>
DC Options: IS_GC
Site Options: IS_INTER_SITE_AUTO_TOPOLOGY_DISABLED
DC object GUID: <GUID>
DC invocationID: <InvocationID>
==== INBOUND NEIGHBORS =====================================
DC=Contoso,DC=com
<Sitename>\<DCname> via RPC DC
DC object GUID: <GUID>
Last attempt @ <DateTime> failed, result 1818 (0x71a):
Can't retrieve message string 1818 (0x71a), error 1815. 123 consecutive
failure(s). Last success @ (never).
DCPromo fails while promoting a new domain controller and you see the following error on the DCPROMO GUI
Active Directory Installation wizard.
The Operation Failed because: Active Directory could not replicate the directory partition
CN=Configuration....from the remote domain controller "server name"
" The remote procedure call was cancelled "The following entries are logged in the DCPROMO logs
<DateTime> [INFO] EVENTLOG (Informational): NTDS General / Service Control : 1004
Active Directory Domain Services was shut down successfully.
<DateTime> [INFO] NtdsInstall for <FQDN fo the domain> returned 1818
<DateTime> [INFO] DsRolepInstallDs returned 1818
<DateTime> [ERROR] Failed to install to Directory Service (1818)
<DateTime> [ERROR] DsRolepFinishSysVolPropagation (Abort Promote) failed with 8001
<DateTime> [INFO] Starting service NETLOGON
<DateTime> [INFO] Configuring service NETLOGON to 2 returned 0
<DateTime> [INFO] The attempted domain controller operation has completed
<DateTime> [INFO] DsRolepSetOperationDone returned 0
While trying to rehost a partition on the Global catalog
repadmin /rehost fail with DsReplicaAdd failed with status
1818 (0x71a)>
DsReplicaAdd fails with status 1818 (0x71a)
Cause
The issue occurs when the destination DC performing inbound replication doesn't receive replication changes within the number of seconds specified in the RPC Replication Timeout (mins)
registry value (the default value is five minutes if the registry entry doesn't exist). You might experience this issue most frequently in one of the following situations:
- You promote a new domain controller into the forest by using the Active Directory Domain Services Configuration Wizard from the Server Manager management console or via the
Install-ADDSDomainController
cmdlet. - Existing domain controllers replicate from source domain controllers that are connected over slow network links.
Note
- Registry value name:
RPC Replication Timeout (mins)
- Registry value location:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters
- Registry value type:
REG_DWORD
If a destination domain controller that is performing RPC-based replication doesn't receive the requested replication package within the time that the RPC Replication Timeout (mins)
registry setting specifies, the destination domain controller ends the RPC connection with the nonresponsive source domain controller and logs a warning event.
Some specific root causes for Active Directory logging 1818 \ 0x71a \ RPC_S_CALL_CANCELLED
include:
- An earlier Network Interface Card driver installed on Domain Controllers could cause failure of a few network features like Scalable Networking Pack (SNP).
- Low bandwidth or network packets drops between source and destination domain controllers.
- The networking device between source and destination device dropping packets.
Note
A speed and duplex mismatch between the NIC and switch on a domain controller could cause dropped frames, resets, duplicate acknowledgments, and retransmitted frames.
Resolution
Inspect the network devices between the source and destination domain controllers (increase the bandwidth of your network connection so that the Active Directory changes replicate in the five-minute timeout period.)
Update the network adapter drivers.
To determine whether an updated network adapter driver is available, contact the network adapter manufacturer or the original equipment manager (OEM) for the computer. The driver must meet Network Driver Interface Specification (NDIS) 5.2 or a later version of this specification.
Check the network binding order:
To configure the network binding order:
Quit any programs that are running.
Right-click Network Neighborhood, and then select Properties.
Select the Bindings tab. In the Show Bindings For box, select All Services.
Double-click each listed service to expand it.
Under each service, double-click each protocol to expand it.
Under each protocol, there are many network adapter icons. Select the icon for your network adapter, and then select Move Up until the network adapter is at the top of the list. Leave the Remote Access WAN Wrapper entries in any order under the network adapter(s).
Note
If you have more than one network adapter, place the internal adapter (with Internet Protocol [IP] address 10.0.0.2 by default on a Small Business Server network) at the top of the binding order, with the external adapter(s) directly below the internal adapter.
The final order should appear similar to:
[1] Network adapter one
[2] Network adapter two (if present)
[3] Remote Access WAN Wrapper
.
.
.
[n] Remote Access WAN WrapperRepeat step f for each service in the dialog box.
After you verify the settings for each service, select All Protocols in the Show Bindings For box. The entry for Remote Access WAN Wrapper doesn't have a network adapter listed. Skip this item. Repeat steps d through f for each remaining protocol.
After you verify that the bindings are set correctly for all services and protocols, select OK. This initializes the rebinding of the services. When this is complete, you're prompted to restart the computer. Select Yes.
Data collection
If you need assistance from Microsoft support, we recommend you collect the information by following the steps mentioned in Gather information by using TSS for Active Directory replication issues.