IAzAuthorizationStore3::IsUpdateNeeded method (azroles.h)

The IsUpdateNeeded method checks whether the persisted version of this authorization store is newer than the cached version. If the cached version of the store is newer, the calling application can update the cached version by calling the UpdateCache method of the AzAuthorizationStore object.

Syntax

HRESULT IsUpdateNeeded(
  [out] VARIANT_BOOL *pbIsUpdateNeeded
);

Parameters

[out] pbIsUpdateNeeded

VARIANT_TRUE if the persisted version of this authorization store is newer than the cached version; otherwise, VARIANT_FALSE.

Return value

If the method succeeds, it returns S_OK.

If the method fails, it returns an error code. For a list of common error codes, see Common HRESULT Values.

Requirements

   
Minimum supported client Windows Vista [desktop apps only]
Minimum supported server Windows Server 2008 [desktop apps only]
Target Platform Windows
Header azroles.h