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Problemas que afectan a las llamadas de enrutamiento directo salientes

Es posible que experimente varios problemas al usar el enrutamiento directo para realizar llamadas salientes desde una aplicación creada en el Kit de desarrollo de software (SDK) de Azure Communication Services a un controlador de borde de sesión (SBC). Entre los problemas se incluyen:

  • Se muestra un identificador de llamador incorrecto o anónimo al destinatario de la llamada.
  • No se establece una conexión con el CLS.
  • Algunos usuarios no pueden realizar llamadas.
  • Ningún usuario de un inquilino puede realizar llamadas.

En este artículo se describen las posibles causas de estos problemas y se proporcionan soluciones que puede probar.

Identificador de llamador incorrecto que se muestra al destinatario

Cuando se usa el enrutamiento directo, la información del identificador de llamada que se entrega al destinatario de la llamada aparece en los From encabezados y P-Asserted-Identity en el mensaje de opciones del Protocolo de inicio de sesión (SIP).

El From encabezado contiene cualquiera de los siguientes elementos:

  • Número de teléfono que se usa como propiedad alternateCallerId de un startCall método en el SDK de llamadas de cliente. Si no se proporcionó un alternateCallerId , se reemplaza por "anónimo".
  • Cadena de número de teléfono que se pasa al crear un PhoneNumberIdentifier objeto en el SDK de Automatización de llamadas
  • Número de teléfono del autor de la llamada original si un SDK de Automatización de llamadas redirige la llamada.
  • Número de teléfono seleccionado como identificador de llamada en la aplicación cliente del agente omnicanal.

El P-Asserted-Identity encabezado contiene el número de teléfono del usuario que se factura por la llamada. Privacy:id indica que la información del encabezado debe estar oculta del destinatario de la llamada.

Causa

Si la información de los From encabezados y P-Asserted-Identity no coincide y si la red telefónica conmutada (RTC) da prioridad a la P-Asserted-Identity información de encabezado sobre la From información de encabezado, se muestra información incorrecta.

Solución

Para asegurarse de que el identificador de llamada correcto se muestra al destinatario de la llamada, configure el SBC para quitar el P-Asserted-Identity encabezado del mensaje SIP INVITE o modificar su contenido.

Conectar a la SBC no establecida

A veces, las llamadas llegan al SBC, pero no se establece ninguna conexión. En esta situación, cuando el SBC recibe un mensaje SIP OPTIONS de Microsoft, devuelve un mensaje de error que incluye códigos de error en el intervalo de 400 a 699.

Cualquiera de las siguientes causas podría impedir una conexión con el CLS.

Causa 1

El mensaje de error SIP procede de otro dispositivo de telefonía que está en la misma red que el SBC.

Resolución 1

Solucione el otro dispositivo para corregir el error. Si necesita ayuda, póngase en contacto con el proveedor del dispositivo.

Causa 2

El proveedor RTC está experimentando algún problema y envía el mensaje de error SIP. Esto es lo más probable si el código de error es SIP 403 o SIP 404.

Resolución 2

Póngase en contacto con el proveedor de RTC para obtener soporte técnico para corregir el problema.

Causa 3

El problema no procede de otro dispositivo de la red o del proveedor RTC. Sin embargo, se desconoce la causa.

Resolución 3

Póngase en contacto con el soporte técnico del proveedor de SBC para corregir el problema.

Algunos usuarios no pueden realizar llamadas

Si la conexión entre Microsoft y el CLS funciona correctamente, pero algunos usuarios o aplicaciones no pueden realizar llamadas, es posible que el problema sea un ámbito incorrecto de un token de acceso de Azure Communication Services.

Causa 1

El token de acceso de Azure Communication Services se creó con un ámbito de chat.

Resolución 1

Asegúrese de que todos los tokens de acceso de Azure Communication Services que se usan para realizar llamadas se generan con un voip ámbito.

Causa 2

Ninguno de los patrones de las rutas de voz coincide con el número marcado.

Resolución 2

Asegúrese de que se cumplen las condiciones siguientes:

  • Hay un patrón en la ruta de voz que coincide con el número marcado.
  • El SBC que se especifica para la ruta de voz es En línea. Si está inactivo, establézcalo en línea o seleccione otro SBC que esté en línea.

Causa 3

El CLS no responde a los mensajes SIP OPTIONS porque algún dispositivo de la red, como un firewall, está bloqueando los mensajes.

Resolución 3

Asegúrese de que las direcciones IP y los FQDN de señalización SIP están permitidas en todos los dispositivos de red que conectan el SBC a Internet. Las direcciones IP que se deben permitir se enumeran en Señalización SIP: FQDN.