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Solución de problemas de Azure Digital Twins Explorer: errores de autenticación

En este artículo se describen las causas y los pasos de resolución al recibir un error de autenticación cuando se ejecuta Azure Digital Twins Explorer.

Síntomas

Al ejecutar Azure Digital Twins Explorer, aparece el siguiente mensaje de error:

Captura de pantalla de un mensaje de error en Azure Digital Twins Explorer, titulado Asegúrese de que tiene los permisos adecuados.

Causas

Causa 1

Este error también puede producirse si la cuenta de Azure no tiene configurados los permisos de control de acceso basado en rol de Azure (Azure RBAC) necesarios en la instancia de Azure Digital Twins. Para acceder a los datos de la instancia, debe tener el rol Lector de datos de Azure Digital Twins o Propietario de datos de Azure Digital Twins en la instancia que está intentando leer o administrar, respectivamente.

Para obtener más información sobre la seguridad y los roles de Azure Digital Twins, vea Seguridad para soluciones de Azure Digital Twins.

Soluciones

Solución 1

Compruebe que el usuario de Azure tiene el rol Lector de datos de Azure Digital Twins en la instancia de Azure Digital Twins si solo está intentando leer sus datos, o el rol Propietario de datos de Azure Digital Twins si está intentando administrar los datos.

Tenga en cuenta que este rol es diferente del...

  • nombre anterior de este rol durante la versión preliminar, Propietario de Azure Digital Twins (versión preliminar) (el rol es el mismo, pero el nombre ha cambiado)
  • rol de propietario de toda la suscripción de Azure Propietario de datos de Azure Digital Twins es un rol dentro de Azure Digital Twins y tiene el ámbito de esa instancia individual de Azure Digital Twins.
  • rol de propietario en Azure Digital Twins. Son dos roles de administración distintos de Azure Digital Twins; Propietario de datos de Azure Digital Twins es el rol que debe usar para la administración.

Si no tiene este rol, establézcalo para solucionar el problema.

Comprobación de la configuración actual

Una manera de comprobar que ha configurado correctamente la asignación de roles es consultar las asignaciones de roles para la instancia de Azure Digital Twins en Azure Portal. Vaya a la instancia de Azure Digital Twins en Azure Portal. Para ello, puede buscarla en la página de instancias de Azure Digital Twins o buscar su nombre en la barra de búsqueda del portal.

Luego, consulte todos sus roles asignados en Control de acceso (IAM) > Asignaciones de roles. La asignación de roles debe aparecer en la lista.

Captura de pantalla de las asignaciones de roles para una instancia de Azure Digital Twins en Azure Portal.

Corrección de problemas

Si no tiene esta asignación de roles, alguien con el rol de propietario en la suscripción a Azure debe ejecutar el siguiente comando para proporcionar al usuario de Azure el rol adecuado en la instancia de Azure Digital Twins.

Si es propietario de la suscripción, puede ejecutar este comando por su cuenta. Si no, póngase en contacto con un propietario para que ejecute este comando en su nombre. El nombre del rol es Propietario de datos de Azure Digital Twins para el acceso de edición o Lector de datos de Azure Digital Twins para el acceso de lectura.

az dt role-assignment create --dt-name <your-Azure-Digital-Twins-instance> --assignee "<your-Azure-AD-email>" --role "<role-name>"

Para más información sobre este requisito de rol y el proceso de asignación, consulte la Configuración de los permisos de acceso del usuario.

Pasos siguientes

Lea los pasos de configuración para crear y autenticar una nueva instancia de Azure Digital Twins:

Obtenga más información sobre la seguridad y los permisos de Azure Digital Twins: