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En este artículo se describen los pasos de solución de problemas y las posibles soluciones para los problemas que se producen al usar clústeres de Azure HDInsight.
Problema
Los registros de syslog del kernel contienen el mensaje de error: watchdog: BUG: soft lockup - CPU
.
Causa
Un error en el kernel de Linux está provocando bloqueos de software de la CPU.
Solución
Aplique una revisión del kernel. El siguiente script actualiza el kernel de Linux y reinicia las máquinas en distintos momentos durante 24 horas. Ejecute la acción de script en dos lotes. El primer lote está en todos los nodos excepto en el nodo principal. El segundo lote está en el nodo principal. No ejecute lotes en el nodo principal y en otros nodos al mismo tiempo.
Vaya al clúster de HDInsight en Azure Portal.
Vaya a las acciones de script.
Seleccione Enviar nuevo y escriba la entrada como se indica a continuación.
Propiedad Value Tipo de script -Custom Nombre Fix for kernel soft lock issue URI de script de Bash https://raw.githubusercontent.com/hdinsight/hdinsight.github.io/master/ClusterCRUD/KernelSoftLockFix/scripts/KernelSoftLockIssue_FixAndReboot.sh
Tipos de nodo Worker, Zookeeper Parámetros N/D Seleccione Conservar esta acción de script... si desea que el script se ejecute cuando se agreguen nuevos nodos.
Seleccione Crear.
Espere a que la ejecución se realice correctamente.
Ejecute la acción de script en el nodo principal con los mismos datos que en el paso 3, pero esta vez especifique: Encabezado.
Espere a que la ejecución se realice correctamente.
Pasos siguientes
Si su problema no aparece o es incapaz de resolverlo, visite uno de nuestros canales para obtener ayuda adicional:
Obtenga respuestas de expertos de Azure mediante el soporte técnico de la comunidad de Azure.
Póngase en contacto con @AzureSupport, la cuenta oficial de Microsoft Azure para mejorar la experiencia del cliente. Esta cuenta pone en contacto a la comunidad de Azure con los recursos adecuados: respuestas, soporte técnico y expertos.
Si necesita más ayuda, puede enviar una solicitud de soporte técnico desde Azure Portal. Seleccione Soporte técnico en la barra de menús o abra la central Ayuda + soporte técnico. Para obtener información más detallada, revise Creación de una solicitud de soporte técnico de Azure. La suscripción a Microsoft Azure incluye acceso al soporte técnico para facturación y administración de suscripciones. El soporte técnico se proporciona a través de uno de los planes de soporte técnico de Azure.