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En este artículo se describen los pasos de solución de problemas y las posibles soluciones para los problemas que se producen al usar componentes de Apache Spark en clústeres de Azure HDInsight.
Problema
Al acceder al servicio Jupyter en HDInsight, verá un cuadro de error que indica "No encontrado". Si comprueba los registros de Jupyter, verá algo parecido a esto:
[W 2018-08-21 17:43:33.352 NotebookApp] 404 PUT /api/contents/PySpark/notebook.ipynb (10.16.0.144) 4504.03ms referer=https://pnhr01hdi-corpdir.msappproxy.net/jupyter/notebooks/PySpark/notebook.ipynb
Blocking Cross Origin API request.
Origin: https://xxx.xxx.xxx, Host: pnhr01.j101qxjrl4zebmhb0vmhg044xe.ax.internal.cloudapp.net:8001
También puede ver una dirección IP en el campo "Origin" (Origen) en el registro de Jupyter.
Causa
Este error se puede producir en los siguientes casos:
Si ha configurado reglas de grupo de seguridad de red (NSG) para restringir el acceso al clúster. Restringir el acceso con reglas de NSG le permitirá seguir accediendo directamente a Apache Ambari y a otros servicios mediante la dirección IP en lugar del nombre del clúster. Sin embargo, al acceder a Jupyter, podría ver un error 404 "No encontrado".
Si ha dado a la puerta de enlace de HDInsight un nombre de DNS personalizado distinto del
xxx.azurehdinsight.net
estándar.
Solución
Modifique los archivos de jupyter.py en estos dos lugares:
/var/lib/ambari-server/resources/common-services/JUPYTER/1.0.0/package/scripts/jupyter.py /var/lib/ambari-agent/cache/common-services/JUPYTER/1.0.0/package/scripts/jupyter.py
Busque la línea que dice
NotebookApp.allow_origin='\"https://{2}.{3}\"'
y cambie los valores porNotebookApp.allow_origin='\"*\"'
.Reinicie el servicio de Jupyter desde Ambari.
Al escribir
ps aux | grep jupyter
en el símbolo del sistema se debe mostrar que permite la conexión de cualquier dirección URL.
Este método es menos seguro que el valor, que ya está presente. Pero se supone que el acceso al clúster está restringido y que alguien externo tiene permitido conectarse al clúster, ya que hemos implementado el NSG.
Pasos siguientes
Si su problema no aparece o es incapaz de resolverlo, visite uno de nuestros canales para obtener ayuda adicional:
Obtenga respuestas de expertos de Azure mediante el soporte técnico de la comunidad de Azure.
Póngase en contacto con @AzureSupport, la cuenta oficial de Microsoft Azure para mejorar la experiencia del cliente. Esta cuenta pone en contacto a la comunidad de Azure con los recursos adecuados: respuestas, soporte técnico y expertos.
Si necesita más ayuda, puede enviar una solicitud de soporte técnico desde Azure Portal. Seleccione Soporte técnico en la barra de menús o abra la central Ayuda + soporte técnico. Para obtener información más detallada, revise Creación de una solicitud de soporte técnico de Azure. La suscripción a Microsoft Azure incluye acceso al soporte técnico para facturación y administración de suscripciones. El soporte técnico se proporciona a través de uno de los planes de soporte técnico de Azure.