Aviso de desuso de RMS SDK 4.2

Aplicable a todas las versiones del SDK 4.2 de RMS antes de marzo de 2020

El 3 de marzo de 2020, se publicó una actualización del SDK de RMS 4.2 para Android, iOS y OSX a través del Centro de descarga de Microsoft. Esta actualización es obligatoria para todas las aplicaciones que usan estas plataformas del SDK de RMS hoy en día.

A partir de enero de 2021, las versiones del SDK de RMS publicadas antes de marzo de 2020 no se conectarán al punto de conexión Azure Rights Management servicio. Las aplicaciones aún no actualizadas no podrán establecer una conexión TLS con el servicio Azure Rights Management cliente.

Motivo del cambio

Las versiones anteriores del SDK de RMS usan anclar certificados para asegurarse de que el cliente habilitado para RMS se comunica con el servicio RMS y recibe un certificado encadenado a una ca raíz específica y esperada.

Los exploradores modernos usan registros de transparencia de certificados para comprobar que los certificados se han emitido a los propietarios de dominios legítimos y que esos certificados se emiten por las autoridades de certificación raíz de confianza.

Para admitir mejor los exploradores modernos, el 1 de diciembre de 2020, Microsoft https://api.aadrm.com actualizará el certificado a un nuevo certificado emitido por una entidad de certificación raíz de confianza global que informe de los certificados emitidos para los registros de transparencia de certificados de confianza de los exploradores modernos. Una vez que se complete este cambio, las versiones heredadas del SDK de RMS que intenten realizar anclas de certificado al certificado raíz esperado no encontrarán ese certificado y no se conectarán.

Impacto del cliente

Las siguientes aplicaciones de Microsoft usan los SDK de RMS hoy. Las actualizaciones se han puesto a disposición de estas plataformas y los dispositivos deben actualizarse antes de la fecha límite de diciembre.

  • Office Pro Plus/2019 para Mac versión 16.40 o posterior.
  • Office 2016 para Mac versión 16.16.27 o posterior.
  • Word, Excel y PowerPoint para iOS versión 2.40.20071600 o posterior.
  • Word, Excel y PowerPoint para Android versión 16.0.12827.20140 o posterior.

Recursos