Nota
El acceso a esta página requiere autorización. Puede intentar iniciar sesión o cambiar directorios.
El acceso a esta página requiere autorización. Puede intentar cambiar los directorios.
No se puede enviar un mensaje reparado si no se implementa el esquema de sobre
Síntoma
Cuando intentas enviar un mensaje que has corregido, A4SWIFT publica el siguiente mensaje:
"El adaptador no pudo transmitir el mensaje que va al puerto http://mrsrtest:80/StsWebReceive/default.aspx?PartnerId=Unparsed&FolderType=MessagesInbox
de envío. Se retransmitirá después del intervalo de reintento especificado para este puerto de envío. Details:"80131600". Para obtener más información, consulte El Centro de ayuda y soporte técnico en https://go.microsoft.com/fwlink/?LinkId=142493.
Causa posible
El esquema de sobre no está implementado. Esto es cierto para cualquier mensajeMT xxx o cualquier mensaje que haya producido un error al analizar.
Solución
Implemente un esquema de sobre para cada esquema de mensaje que esté utilizando (<unidad>:\Archivos de programa\Microsoft BizTalk Accelerator for SWIFT <versión> Message Pack \SWIFT Messages\ A4SWIFT-SRG<versión>\Categoría n\MTxxx.xsd) y para el esquema de sobre sin analizar (<unidad>:\Archivos de programa\Microsoft BizTalk Accelerator for SWIFT <versión> Message Pack \SWIFT Messages\ A4SWIFT-SRG<versión>\Mensaje Sin Analizar\EnvelopeUnparsedMessage.xsd). Para obtener más información, consulte Implementación de esquemas de A4SWIFT.
No se puede enviar un mensaje fijo sin analizar desde una biblioteca del sitio MRSR con un nombre distinto al de "Unparsed".
Síntoma
Al intentar enviar un mensaje sin análisis que se ha corregido desde una biblioteca de documentos del sitio MRSR que no se denomina "Sin análisis", se produce un error en la operación.
Causa posible
A4SWIFT no puede enviar correctamente un mensaje de una biblioteca que no se denomina "Sin analizar". Si tiene una biblioteca de documentos "No analizada" existente en el sitio MRSR antes de instalar la característica MRSR (reparación de mensajes), A4SWIFT configurará una biblioteca para un mensaje no analizado titulado "No analizados" con un sufijo. Cuando recibe un mensaje que no pudo analizarse con A4SWIFT, enrutará el mensaje a esa biblioteca que creó. Sin embargo, al intentar enviar un mensaje desde esa biblioteca, se producirá un error en la operación.
Solución
Quite la característica MRSR, elimine la biblioteca sin analizar y vuelva a instalar la característica MRSR.
No se puede volver a repetir un mensaje en un flujo de trabajo de dos fases
Síntoma
Si rechaza un mensaje en la etapa de reparación de un flujo de trabajo que solo tiene una etapa de creación y una etapa de reparación, el envío falla. BizTalk Server enruta el mensaje de nuevo al Cuadro de mensajes y publica el siguiente mensaje de error:
"No se pudo restablecer a la primera fase del flujo de trabajo".
Causa posible
El bucle de mensajes no se admite para un flujo de trabajo que tenga solo una fase de creación y una fase de reparación.
Solución
Agregue otra fase al flujo de trabajo de dos fases o cancele el envío.
No se puede abrir un mensaje en la bandeja de entrada de reparación en MRSR
Síntoma
Al intentar abrir un mensaje en la bandeja de entrada de reparación de MRSR, recibirá el siguiente mensaje de error en una ventana emergente.
"No se puede abrir la base de datos solicitada en el inicio de sesión "A4SWIFT". Error de inicio de sesión. Error de inicio de sesión del usuario "NT AUTHORITY\NETWORK SERVICE".
Causa posible
La cuenta de inicio de sesión de la aplicación web en la que se ejecuta el servicio web de A4SWIFT_MRSR es Servicio de red, no una cuenta de dominio o local que se encuentra en el grupo Usuarios de A4SWIFT.
Solución
Cambie la cuenta de inicio de sesión de la aplicación web en la que se ejecuta el servicio web A4SWIFT_MRSR.
Para cambiar la cuenta de inicio de sesión de la aplicación web en la que se ejecuta el servicio web A4SWIFT_MRSR
Haga clic en Inicio, seleccione Todos los programas, Herramientas administrativas y, a continuación, haga clic en Administrador de Internet Information Services (IIS).
En el Administrador de IIS, expanda el <nodo nombre> del servidor (equipo local), el nodo Grupos de aplicaciones y el nodo Sitios web. En el nodo Sitios web, expanda el nodo Sitio web predeterminado .
En el nodo Sitio web predeterminado, haga clic con el botón secundario en A4SWIFT_MRSR y, a continuación, haga clic en Propiedades.
En el cuadro de diálogo Propiedades de A4SWIFT_MRSR, anote el grupo de aplicaciones.
En el cuadro de diálogo Administrador de IIS, en el nodo Grupos de aplicaciones, haga clic con el botón derecho en el grupo de aplicaciones para A4SWIFT_MRSR y, a continuación, haga clic en Propiedades.
En el cuadro de diálogo Propiedades del <nombre del grupo de aplicaciones>, haga clic en la pestaña Identidad. Si se hace clic en Predefinido y se selecciona Servicio de red , haga clic en Configurable, escriba la cuenta local o de dominio y, a continuación, escriba la contraseña. Haz clic en Aceptar.
No se procesa un mensaje creado en el sitio MRSR en un equipo localizado
Síntoma
Cuando un usuario que trabaja en una versión en inglés de A4SWIFT que se ejecuta en una plataforma localizada crea un mensaje en un formulario de InfoPath en MRSR y envía el mensaje correctamente, el mensaje parece ser consumido por la reparación de mensajes y la orquestación de nuevo envío, pero no se procesa correctamente. El mensaje se envía a la bandeja de salida, pero el adaptador de BizTalk no lo recoge. No se publica ningún error o advertencia en el Visor de eventos y no hay ningún registro de una instancia de orquestación en ejecución en HAT.
Causa posible
La ruta especificada como URI para la ubicación de recepción de la bandeja de salida de STS contiene el nombre en inglés, no el nombre localizado.
Solución
Cambie la dirección URI para la ubicación de recepción de STS.Outbox de la siguiente manera:
En la Consola de administración de BizTalk Server 2009, expanda los nodos Grupo de BizTalk, Aplicaciones y Aplicación de BizTalk 1.
Haga clic en Ubicaciones de recepción.
Haga doble clic en Sts.Outbox.Location.
En el cuadro de diálogo Propiedades de ubicación de recepción, haga clic en Configurar.
En el cuadro de diálogo Propiedades de transporte, reemplace el valor de dirección URL de SharePointSite por el equivalente localizado.
Haga clic en Aceptary, a continuación, haga clic en Aceptar.
La eliminación de un rol mientras procesa un mensaje da como resultado la eliminación incompleta de documentos y artefactos
Síntoma
Al quitar un rol en el cliente web de perfil, se publica un cuadro de diálogo que indica que se quitarán todos los documentos y artefactos asociados al rol. Sin embargo, la función no se elimina del departamento en la consola de administración de A4SWIFT y las carpetas de documentos de la función (Bandeja de entrada y Elementos enviados) no se eliminan de MRSR. La parte, el puerto de envío y el contrato asociados al rol se quitan, y el perfil del rol se desactiva.
Causa posible
Un mensaje todavía está en la bandeja de entrada del rol en MRSR y el mensaje está abierto en su formulario de InfoPath.
Solución
Elimine manualmente el mensaje de la bandeja de entrada del sitio MRSR y, a continuación, elimine la biblioteca de documentos asociada al rol que estaba quitando. Cierre el formulario y vuelva a eliminar la función.
Se produce un error en el procesamiento de mensajes como resultado de un error en la directiva maestra de BIC
Síntoma
Al enviar un mensaje para su procesamiento, recibirá el siguiente error:
"Error al ejecutar BicMasterPolicy. Compruebe la directiva para ver los valores válidos".
Causa posible
El nombre de SQL Server, el nombre de la base de datos BIC y el valor de seguridad integrada en el archivo BIC_Master_Policy.xml en <unidad de disco>:\Archivos de programa\ Microsoft BizTalk Accelerator for SWIFT< versión> Message Pack\SWIFT Messages\A4SWIFT-SRG<versión>\Base Policies están incluidos entre comillas dobles. Para habilitar la validación de BIC, escriba estas cadenas en el archivo de BIC_Master_Policy.xml predeterminado, tal como se describe en Habilitación de la validación de códigos de identificador bancario.
Solución
Para reparar la política maestra de BIC, proceda de la siguiente manera:
Nota:
Para obtener más información sobre la implementación de la directiva maestra de BIC, consulte Implementación de reglas de BRE.
En Business Rule Composer, quite la versión 1.0 de la BIC_Master_Policy y elimine el BIC_Master_Policy.
En un editor de texto, como el Bloc de notas, abra BIC_Master_Policy.xml en <unidad>:\Archivos de programa\ Acelerador de Microsoft BizTalk para paquete de mensajes de la versión> SWIFT<\MENSAJES SWIFT\A4SWIFT-SRG<versión>\Directivas base. Quite las comillas dobles alrededor del nombre de SQL Server, el nombre de la base de datos BIC y el valor de seguridad integrado.
En el Asistente para la implementación del motor de reglas de negocios, importe BIC_Master_Policy.xmly, a continuación, implemente BIC_Master_Policy.xml.
En la MMC de Servicios, reinicie el servicio de actualización del Motor de Reglas y el servicio Host de Recepción de BizTalk.
A4SWIFT no podrá procesar un mensaje no preparado sin permisos de base de datos adecuados.
Síntoma
Cuando se descarta un mensaje que A4SWIFT no puede interpretar, A4SWIFT no puede procesar el mensaje y falla con una excepción no detectada.
Causa posible
Hay un problema de permiso de base de datos. La cuenta de inicio de sesión del servicio de BizTalk, que de forma predeterminada es HostSvc, no se incluye en los grupos administradores de A4SWIFT y usuarios de A4SWIFT.
Solución
Agregue la cuenta de inicio de sesión del servicio de BizTalk a los grupos administradores de A4SWIFT y usuarios de A4SWIFT.
Un tiempo de espera del formulario de reparación de InfoPath puede dar lugar a dos copias de un mensaje en distintas fases del flujo de trabajo de reparación.
Síntoma
Al enviar un mensaje desde un formulario de InfoPath (para cualquier fase de flujo de trabajo), si se produce un error en el envío del formulario, el error podría dar lugar a dos copias del mensaje. Un mensaje todavía está en la bandeja de entrada para las etapas actuales, y el otro mensaje está en la bandeja de entrada para la siguiente función en el flujo de trabajo. Si intenta procesar estos mensajes, se producirá lo siguiente:
Si envía el mensaje desde la bandeja de entrada para el siguiente rol del flujo de trabajo, el mensaje seguirá su curso en el flujo de trabajo.
Si envía el mensaje desde la bandeja de entrada para la fase actual después de que el mensaje enviado desde la bandeja de entrada de la siguiente fase haya completado el procesamiento, el mensaje enviado desde la bandeja de entrada actual se suspenderá con un error de enrutamiento.
Si envía el mensaje en la bandeja de entrada para la fase actual antes de que el mensaje enviado desde la bandeja de entrada de la siguiente fase haya completado el procesamiento, el mensaje enviado desde la bandeja de entrada de la fase actual se devolverá a la bandeja de entrada para esa fase y recibirá el siguiente error: "Restablecer flujo de trabajo debido a: ya sea que el mensaje se manipuló o el usuario no es válido para esta fase". Después de esto, si envía el mensaje desde la bandeja de entrada para la siguiente fase, también se restablecerá el flujo de trabajo para él. Se devolverá a la bandeja de entrada de la etapa actual y usted recibirá el error anterior.
Causa posible
El formulario de InfoPath ha enviado el mensaje a BizTalk Server a través de Microsoft Windows Sharepoint Services y un servicio web personalizado que realiza validaciones. El envío de un mensaje se realiza en varios pasos y estos pasos no son transaccionales, ya que Windows Sharepoint Services no es transaccional. Para dar cabida a esta limitación, las orquestaciones MRSR han integrado la lógica de recuperación para detectar y recuperarse de errores derivados del envío de mensajes. Las orquestaciones MRSR siempre impiden que los mensajes duplicados se envíen a SWIFT.
Solución
Si esto ocurre, debe elegir el mensaje que se encuentra más adelante en el flujo de trabajo y completar su flujo de trabajo antes de intentar procesar los demás mensajes que se encuentran en las fases anteriores del flujo de trabajo. Una vez que el mensaje que se encuentra más a lo largo del flujo de trabajo ha completado el procesamiento, puede eliminar el segundo mensaje (que se suspendió con un error de enrutamiento) tal como se ve adecuado.
Si el mensaje que está más adelante en el flujo de trabajo no completó el procesamiento antes de procesar el segundo mensaje, debe reparar de nuevo el mensaje que está más a lo largo del flujo de trabajo en el formulario de reparación de InfoPath y, a continuación, enviarlo. Permitir que complete el procesamiento y, a continuación, envíe el segundo mensaje. Una vez suspendido el segundo mensaje, elimínelo.
Un nuevo envío sin fase de comprobación dará lugar a un mensaje suspendido
Síntoma
Cuando envía un nuevo mensaje en un flujo de trabajo que no tiene ninguna fase de comprobación, el mensaje se suspende.
Causa posible
La falta de una fase de comprobación da como resultado un mensaje suspendido si A4SWIFT_MRSRLastStage no está establecido en Crear.
Solución
Use una suscripción de A4SWIFT_MRSRLastStage == Crear para asegurarse de que el mensaje se enruta correctamente.
La validación del mensaje da como resultado un "error de análisis" en el panel de tareas formulario de InfoPath
Síntoma
El botón Validar mensaje en el panel de tareas del formulario de InfoPath muestra "error de análisis" sin ninguna descripción.
Solución
Reinicie el servicio web MRSR o realice iisreset.
Al publicar un formulario de InfoPath se produce un error de autorización
Síntoma
Al publicar un formulario de InfoPath, se produce un error de autorización.
Solución
Reemplace el nombre del equipo por localhost en la dirección URL del sitio MRSR.
Panel de tareas de formulario de InfoPath muestra el código fuente HTML
Síntoma
El panel de tareas de formulario de InfoPath muestra código fuente HTML en lugar de controles web.
Solución
Vaya a Herramientas->pestaña Seguridad ->Zona de Internet, y habilite Abrir archivo basado en el contenido, no en la extensión en Misceláneos.
El sitio web del Cliente Web Perfil genera un error de autenticación.
Síntoma
El sitio web del cliente web de perfiles muestra un error de autenticación.
Solución
Ejecute los grupos de aplicaciones BTSharePointAdapterWSAppPool y DefaultAppPoolApplication en Internet Information Services (IIS) bajo la cuenta de administrador.