Solución de problemas de Sign-On único de empresa
En esta tema se proporciona información sobre los problemas comunes que se pueden producir al usar el inicio de sesión único (SSO) empresarial.
Cuando empiece a solucionar problemas con el entorno de SSO, puede resultar útil seguir los elementos de la tabla siguiente para asegurarse de que todos los componentes funcionan del modo esperado:
Pregunta | Comentarios |
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¿Hay algo relacionado con el sistema SSO en el registro de eventos de la aplicación? | Los mensajes de SSO del registro de eventos permiten acotar el problema existente en el sistema SSO. El origen de los mensajes provenientes del sistema SSO es ENTSSO. Importante: Muchos de los errores y eventos de SSO aparecen como advertencias en el registro de eventos, no como errores. El sistema SSO genera una advertencia cuando el problema afecta a un solo cliente del servicio SSO, y genera errores cuando el problema afecta a todo el sistema SSO (a todos los clientes). |
¿El servicio SSO está instalado correctamente? ¿Se inicia del modo previsto? ¿En qué cuenta de servicio se está ejecutando el servicio SSO? |
Asegúrese de que el servicio SSO está correctamente instalado y que la cuenta de servicio pertenece al grupo de administradores de SSO. |
¿Dónde está la base de datos de SSO? | Use la línea de comandos ssoconfig -showdb. Para obtener más información sobre este comando, vea Cómo mostrar la información de la base de datos de SSO. |
¿Qué servidor de SSO se está usando? | Use la línea de comandos ssomanage -showserver. Para obtener más información sobre este comando, vea Cómo establecer el servidor SSO. |
¿Qué es la cuenta de administrador de SSO? | Use la línea de comandos ssomanage –displaydb. Para obtener más información sobre este comando, vea Cómo mostrar la información de la base de datos de SSO. |
¿Está todo habilitado correctamente? | Use la línea de comandos ssomanage –displaydb. Para obtener más información sobre este comando, vea Cómo mostrar la información de la base de datos de SSO. |
¿Existen las aplicaciones afiliadas? | Use la línea de comandos ssomanage –listapps all. Para obtener más información sobre este comando, vea Cómo enumerar aplicaciones afiliadas. |
¿La aplicación afiliada específica parece correcta? ¿Qué cuentas utiliza esta aplicación afiliada? |
Use el nombre> de la aplicación ssomanage –displayapp<de la línea de comandos. Para obtener más información sobre este comando, vea Cómo enumerar las propiedades de una aplicación afiliada. |
¿Existe alguna asignación para esta aplicación afiliada? | Use el nombre> de la aplicación ssomanage –listmappings< de la línea de comandos. Para obtener más información sobre este comando, vea Cómo enumerar asignaciones de usuarios. |
¿Qué cuentas pertenecen a los grupos de SSO? | Compruebe la pertenencia al grupo de todos los grupos y cuentas de SSO. |
¿La aplicación COM+ del servidor de SSO se está ejecutando del modo previsto? | Compruebe la aplicación COM+ del servidor de SSO. Nota: También puede comprobar el registro de eventos para obtener información detallada, como mensajes de evento y advertencia. |
Problemas conocidos
El servicio ENTSSO no consigue iniciarse
Problema
El Servicio ENTSSO no consigue iniciarse.
Causa
El Servicio ENTSSO no se podrá iniciar si no se ejecuta con una cuenta de administrador de SSO válida.
Resolución
Especifique una cuenta de administrador de SSO válida para el Servicio ENTSSO y reinicie éste desde el complemento Administrador de control de servicios.
Los servicios de BizTalk que dependen del inicio de sesión único empresarial (ENTSSO) no se inician después de reiniciar el equipo
Problema
BTSSvc$BizTalkServerApplication depende del Servicio de inicio de sesión único empresarial (ENTSSO) y después de reiniciar el equipo puede causar un tiempo de espera durante el inicio.
Causa
El Servicio de inicio de sesión único empresarial puede tardar unos 3 minutos en iniciarse.
Resolución
Configure el servicio “Grupo de BizTalk del servicio de BizTalk: BizTalkServerApplication" con la opción de tipo de inicio automático (inicio retrasado). De este modo, el servicio se iniciará después de que todos los servicios automáticos finalicen sus rutinas de inicio.
No puede obtener acceso a una aplicación afiliada
Problema
El Servicio de inicio de sesión único empresarial deshabilita una aplicación afiliada si la cuenta de administrador de aplicación asociada con él no es válida.
Causa
La cuenta de administrador de aplicación de SSO no es válida.
Resolución
Antes de crear una aplicación afiliada, asegúrese de que la cuenta de administrador de aplicación de SSO es válida. Después deberá habilitar la aplicación afiliada para poder usarla.
Se produce un error RPC al conectarse a un equipo cliente
Problema
Cuando un usuario ejecuta un comando como ssomanage -displayapp<applicationname>, donde el equipo intenta conectarse a un servidor SSO remoto para recuperar la información, recibe el siguiente error: ERROR: 0x800706BA: El servidor RPC no está disponible.
Causa
Este error se produce cuando el usuario especifica la información de servidor incorrecta o cuando el servicio SSO no está disponible en el servidor remoto.
Resolución
Siga los pasos descritos en Cómo establecer el servidor SSO para asegurarse de que está conectado al servidor de SSO correcto.
Asegúrese de que el Servicio SSO está habilitado y en ejecución en el servidor de SSO al que se conecta.
El secreto principal falta o está dañado
Problema
El secreto principal falta o está dañado. Normalmente, se genera durante la configuración. Si falta el secreto, en el registro de eventos aparecerá uno de los mensajes siguientes cuando se inicie el Servicio de inicio de sesión único (SSO) empresarial.
Id. del mensaje=10520
Gravedad=Advertencia
SSO_WARN_NO_SECRETS
Id. del mensaje=10565
Gravedad=Error
SSO_ERROR_SECRET_VALIDATE_FAILED
Id. del mensaje=10521
Gravedad=Error
SSO_ERROR_SECRETS_NOT_LOADED
Causa
Es posible que este problema se produzca si se genera un secreto mientras se estaba ejecutando el Servicio de inicio de sesión único (SSO) empresarial en una cuenta de servicio y, posteriormente, se cambia la cuenta de servicio. El secreto se almacena en el Registro en formato cifrado mediante una clave basada en la identidad de la cuenta de servicio (en la cual se ejecuta ENTSSO).
Resolución
Cambie la cuenta de servicio con la que se ejecuta ENTSSO a la cuenta de servicio original cuando se creó el secreto principal.
Para cambiar la cuenta de servicio ENTSSO:
Haga una copia de seguridad del secreto principal. Para obtener más información, vea Cómo realizar una copia de seguridad del secreto maestro.
Detenga los Servicios de inicio de sesión único (SSO) empresarial.
Cambie la cuenta de servicio.
Reinicie el SSO y haga caso omiso de los errores del registro de eventos de un secreto dañado, si éstos se produjeran.
Restaure el secreto principal. Para obtener más información, vea Cómo restaurar el secreto maestro.