Compartir a través de


Solución de problemas de Internet Information Services

Microsoft Internet Information Services (IIS) se usa ampliamente en Microsoft BizTalk Server para diversas funciones, incluidos los adaptadores HTTP, SOAP y Windows SharePoint Services. En esta tema se explican algunos problemas conocidos que se puede encontrar en IIS y las posibles soluciones a estos problemas.

Problemas conocidos

Es posible que los errores incluidos en este tema no se muestren a menos que configure Internet Explorer para que deshabilite los mensajes de error descriptivos de HTTP.

Para configurar Internet Explorer de modo que deshabilite los mensajes de error descriptivos de HTTP

  1. En el menú Herramientas, haga clic en Opciones de Internet.

  2. En la pestaña Opciones avanzadas , en la sección Exploración , desactive la casilla Mostrar mensajes de error HTTP descriptivos y, a continuación, haga clic en Aceptar.

  3. Cierre Internet Explorer.

Al obtener acceso a una página web en un servidor IIS, se produce el error “HTTP 404 – Archivo no encontrado”

Problema

Al intentar obtener acceso a una página web en un servidor IIS, se muestra un error similar al siguiente:

No se encontró la página

O bien

HTTP 404 – Archivo no encontrado

Causa

Este error puede producirse por los siguientes motivos:

  • Se ha cambiado el nombre del servicio solicitado.

  • El archivo solicitado se ha movido a otra ubicación o se ha eliminado.

  • El archivo solicitado no está disponible temporalmente debido a mantenimiento, actualizaciones u otros motivos desconocidos.

  • El archivo solicitado no existe.

  • IIS 6.0: el tipo MIME o la extensión de servicio Web adecuada no están habilitados.

  • Un directorio virtual se asigna a la raíz de una unidad en otro servidor.

Resolución

Siga los pasos descritos en la sección RESOLUCIÓN del artículo de Microsoft Knowledge Base 248033, "Common reasons IIS Server returns "HTTP 404 - File not found" error "HTTP 404 - File not found" available at https://support.microsoft.com/kb/248033.

Al obtener acceso a una página web en un servidor IIS, se produce el error “No se pudo encontrar el servidor o error DNS”

Problema

Al intentar obtener acceso a una página web en un servidor IIS, se muestra un error similar al siguiente:

No se puede mostrar la página

O bien

No se pudo encontrar el servidor o error DNS

Causa

Este error puede producirse por los siguientes motivos:

  • Su configuración de conexión de Internet Explorer es incorrecta.

  • Se ha instalado software de servidor de seguridad o proxy incompatible, configurado de forma incorrecta o con funcionamiento incorrecto.

  • Hay una entrada incorrecta en un archivo de hosts.

  • Su adaptador de red no está funcionando correctamente o tiene instalados controladores de adaptador de red incompatibles.

Resolución

Siga los pasos descritos en la sección RESOLUCIÓN del artículo de Microsoft Knowledge Base 326155, "Mensaje de error al intentar acceder a un sitio web en Internet Explorer: "Página no se puede mostrar"" disponible en https://support.microsoft.com/kb/326155.

Al obtener acceso a una página Web en un servidor IIS, se produce el error “401 – Acceso denegado”

Problema

Al intentar obtener acceso a una página web en un servidor IIS, se muestra un error similar al siguiente:

401 – Acceso denegado

Causa

IIS define varios errores 401 diferentes que indican una causa más específica del error. Estos códigos de error específicos se muestran en el explorador:

  • 401.1 – Error en el inicio de sesión.

  • 401.2 – Error en el inicio de sesión debido a la configuración del servidor.

  • 401.3 – No autorizado debido a ACL en el recurso.

  • 401.4 – No autorizado: error de autorización debido a un filtro instalado en el servidor web.

  • 401.5 – Error de autorización debido a una aplicación ISAP o CGI.

  • 401.7 – Acceso denegado por directiva de autorización de URL en el servidor web. Este código de error es específico de IIS 6.0.

    Para obtener una lista completa de los códigos de estado de IIS 7.0, consulte el artículo de Microsoft Knowledge Base 943891, "Los códigos de estado HTTP en IIS 7.0" disponibles en https://support.microsoft.com/kb/943891.

Resolución

Siga los pasos descritos en Directrices para resolver problemas de permisos de IIS para resolver problemas de permisos de IIS.

Al obtener acceso a una página web en un servidor IIS, se produce el error “ 500 – Error interno del servidor”

Problema

Al intentar obtener acceso a una página web en un servidor IIS, se muestra un error similar al siguiente:

500 - Internal server error

Causa

Este mensaje de error lo pueden provocar una amplia gama de problemas del servidor.

Solución

Para solucionar el problema, haga lo siguiente:

  • Revise el registro de la aplicación del servidor IIS para obtener información acerca de la causa del error.

  • Revise los archivos de registro de IIS o de HTTPERR para obtener información que pueda ser útil a la hora de determinar la causa del error. De forma predeterminada, los archivos de registro de IIS en un equipo que ejecuta sistemas operativos Windows Server se encuentran en el directorio siguiente:

    %WinDir%\system32\LogFiles\W3SVC1\

    Nota

    %WinDir% es un marcador de posición para la ubicación del directorio de Windows en el servidor IIS.

    De forma predeterminada, en un equipo con Windows Server 2008 o Windows Vista, los archivos de registro de IIS se encuentran en el siguiente directorio:

    C:\inetpub\logs\LogFiles\W3SVC1\

    De forma predeterminada, los archivos de registro HTTPERR en Windows Server se encuentran en el directorio siguiente:

    %WinDir%system32LogFilesHTTPERR

    Nota

    El archivo de registro HTTPERR solo está disponible en un equipo con Windows Server 2008 SP2 o Windows Vista.

Al obtener acceso a una página web en un servidor IIS, se produce el error “Servicio no disponible”

Problema

Al intentar obtener acceso a una página web en un servidor IIS, se muestra un error similar al siguiente:

Servicio no disponible

Causa

La causa más común de este error es que el grupo de aplicaciones (IIS 6.0 e IIS 7.0) para la página web se ha detenido. Esto suele ocurrir si el grupo de aplicaciones o la aplicación COM+ están configurados con una identidad para la que el nombre de usuario y la contraseña especificados no son válidos.

Resolución

Siga los pasos descritos en la sección "Configuración de la identidad del proceso de host de aplicación de IIS" del tema Directrices para resolver problemas de permisos de IIS para establecer la identidad del proceso de host adecuada.

Consulte también

Directrices para solucionar problemas de permisos de IIS