Solución de problemas de licencia para Microsoft Defender para punto de conexión en macOS
Se aplica a:
- Microsoft Defender para punto de conexión en macOS
- Microsoft Defender para punto de conexión Plan 1
- Microsoft Defender para punto de conexión Plan 2
- Microsoft Defender XDR
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No se encontró ninguna licencia
Cuando se implementa Microsoft Defender para punto de conexión en macOS, aparece un mensaje de error con una x encima de la Microsoft Defender para punto de conexión en el escudo de macOS.
Seleccione el símbolo x .
Mensaje
Al seleccionar el símbolo x , verá las opciones como se muestra en la captura de pantalla siguiente:
Al seleccionar Acción necesaria, recibirá el mensaje de error como se muestra en la captura de pantalla siguiente:
Este mensaje se encuentra de otra manera: si usa el terminal para especificar el estado de mdatp sin comillas dobles, se muestra el mensaje como se muestra en la captura de pantalla siguiente:
Causa
Puede encontrar un error si ha implementado o instalado el Microsoft Defender para punto de conexión en el paquete macOS Descargar paquetes de instalación, pero es posible que no haya ejecutado el script de configuración Descargar el paquete de incorporación que contiene la configuración de licencia. Para obtener información sobre la solución de problemas en este escenario, consulte Si no ejecutó el script de configuración.
Puede encontrar un mensaje de error cuando el Microsoft Defender para punto de conexión en el agente de macOS no está actualizado. Para obtener información sobre la solución de problemas en este escenario, consulte Si Microsoft Defender para punto de conexión en macOS no está actualizado.
Puede encontrar un mensaje de error si quitó y reenbordó mac desde Microsoft Defender para punto de conexión en macOS.
Puede encontrar un mensaje de error si no se asigna una licencia a un usuario. Para obtener información sobre la solución de problemas en este escenario, consulte Si una licencia no está asignada a un usuario.
Soluciones
Si no ejecutó el script de configuración
En esta sección se describen las medidas de solución de problemas cuando el mensaje de error o advertencia se debe a la no ejecución del script de configuración. El script contiene la configuración de licencia cuando se instala e implementa la Microsoft Defender para punto de conexión en el paquete macOS.
En función de la herramienta de administración de implementación usada, siga las instrucciones específicas de la herramienta para incorporar el paquete (registre la licencia), tal como se describe en la tabla siguiente:
Administración | Instrucciones de implementación de licencias (instrucciones de incorporación) |
---|---|
Intune | Descarga del paquete de incorporación |
JamF | Paso 1: Obtener el paquete de incorporación de Microsoft Defender para punto de conexión |
Otro MDM | Configuración de licencia |
Instalación manual | Descargar paquetes de instalación e incorporación; y paquete de incorporación |
Nota:
Si el paquete de incorporación se ejecuta correctamente, la información de licencias se ubicará en /Library/Application Support/Microsoft/Defender/com.microsoft.wdav.atp.plist
.
Si Microsoft Defender para punto de conexión en macOS no está actualizado
Para escenarios en los que Microsoft Defender para punto de conexión en macOS no está actualizado, debe actualizar el agente.
Si se ha quitado Microsoft Defender para punto de conexión en macOS
Cuando el script de offboarding se ejecuta en macOS, guarda un archivo en /Library/Application Support/Microsoft/Defender/
y se denomina com.microsoft.wdav.atp.offboarding.plist
.
Si el archivo existe, impedirá que el macOS se incorpore de nuevo. Elimine el archivo com.microsoft.wdav.atp.offboarding.plist que ejecuta de nuevo el script de incorporación.
Si una licencia no está asignada a un usuario
En el portal de Microsoft Defender (security.microsoft.com), seleccione Configuración y, a continuación, seleccione Puntos de conexión.
Seleccione Licencias.
Seleccione Ver y comprar licencias en el Centro de administración de Microsoft 365. Aparece la siguiente pantalla en el portal de Centro de administración de Microsoft 365:
Active la casilla de la licencia que desea comprar de Microsoft y selecciónela. Aparece la pantalla que muestra los detalles de la licencia elegida:
Seleccione el vínculo Asignar licencias .
Aparece la siguiente pantalla:
Seleccione + Asignar licencias.
Escriba el nombre o la dirección de correo electrónico de la persona a la que desea asignar esta licencia. Aparece la siguiente pantalla, que muestra los detalles del asignador de licencias elegido y una lista de opciones.
Active las casillas de Auditoría avanzada, Microsoft Defender XDR y Microsoft Defender para punto de conexión de Microsoft 365. Después, seleccione Guardar.
Al implementar estas opciones de solución (cualquiera de ellas), si se han resuelto los problemas de licencia y, a continuación, ejecuta el estado de mdatp, debería ver los resultados siguientes:
Inicio de sesión con su cuenta microsoft
Mensaje
Inicie sesión con su cuenta Microsoft para empezar.
Create nueva cuenta o cambiar a una aplicación empresarial.
Causa
Ha descargado e instalado Microsoft Defender para individuos en macOS además de Microsoft Defender para punto de conexión instaladas anteriormente.
Solución
Seleccione Cambiar a una aplicación empresarial para cambiar a Experiencia empresarial.
También puede suprimir el cambio a la experiencia para individuos en equipos inscritos en MDM mediante la inclusión de userInterface/consumerExperience en la configuración de Defender:
<key>userInterface</key>
<dict>
<key>consumerExperience</key>
<string>disabled</string>
</dict>
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- Configurar la Microsoft Defender para punto de conexión en directivas de macOS en Jamf Pro: obtenga información sobre cómo configurar el Microsoft Defender para punto de conexión en directivas de macOS en Jamf Pro.
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Sugerencia
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