Requisitos de sistema de .NET Framework

En las tablas de este artículo se indican los requisitos de hardware, sistema operativo y software de las siguientes versiones de .NET Framework:

  • .NET Framework 4.5 y sus versiones secundarias (4.5.1 y 4.5.2).
  • .NET Framework 4.6 y sus versiones secundarias (4.6.1 y 4.6.2).
  • .NET Framework 4.7 y sus versiones secundarias (4.7.1 y 4.7.2).
  • .NET Framework 4.8 y su versión secundaria (4.8.1).

Para información sobre las versiones de .NET Framework anteriores a .NET Framework 4.5, vea Versiones y dependencias de .NET Framework.

Los entornos de desarrollo que permiten desarrollar aplicaciones para .NET Framework tienen otros requisitos diferentes.

Importante

Todas las versiones de .NET Framework a partir de .NET Framework 4 son actualizaciones en contexto, por lo que solo puede estar presente en un sistema una sola versión 4.x. Además, determinadas versiones de .NET Framework están preinstaladas en algunas versiones del sistema operativo Windows. Esto significa que:

  • Si hay alguna versión posterior a 4.x que ya está instalada en el equipo, no se puede instalar una versión anterior a 4.x.
  • Si el sistema operativo viene preinstalado con una determinada versión de .NET Framework, no se puede instalar una versión anterior a 4.x en el mismo equipo.
  • Si se instala una versión posterior, no es necesario desinstalar primero la versión anterior.

Para obtener información y vínculos de descarga, vea Instalar .NET Framework para desarrolladores.

Para obtener información sobre el ciclo de vida de soporte técnico de las versiones de .NET Framework, vea Microsoft Support Lifecycle.

Requisitos de hardware

Requisito
Procesador 1 GHz
RAM 512 MB
Espacio mínimo en disco (32 bits) 4.5 GB
Espacio mínimo en disco (64 bits) 4.5 GB

Requisitos de instalación

Necesita tener privilegios de administrador para poder instalar .NET Framework. Si no tiene derechos de administrador en el equipo en el que quiere instalar .NET Framework, póngase en contacto con el administrador de red.

Sistemas operativos de cliente admitidos

Sistema operativo Ediciones compatibles Preinstalado con el sistema operativo Instalable por separado
Windows 11 64 bits .NET Framework 4.8 .NET Framework 4.8.1
Actualización de Windows 10 2022
(versión 22H2)
32 bits y 64 bits .NET Framework 4.8 .NET Framework 4.8.1
Actualización de Windows 10 de noviembre de 2021
(versión 21H2)
32 bits y 64 bits .NET Framework 4.8 .NET Framework 4.8.1
Actualización de Windows 10 de mayo de 2021
(versión 21H1)
32 bits y 64 bits .NET Framework 4.8 .NET Framework 4.8.1
Actualización de octubre de 2020 de Windows 10
(versión 20H2)
32 bits y 64 bits .NET Framework 4.8 .NET Framework 4.8.1
Actualización de Windows 10 de mayo de 2020
(versión 2004)
32 bits y 64 bits .NET Framework 4.8 --
Actualización de Windows 10 de noviembre de 2019
(versión 1909)
32 bits y 64 bits .NET Framework 4.8 --
Actualización del 10 de mayo de 2019 de Windows 2019
(versión 1903)
32 bits y 64 bits .NET Framework 4.8 --
Actualización de octubre de 2018 de Windows 10
(versión 1809)
32 bits y 64 bits .NET Framework 4.7.2 .NET Framework 4.8
Actualización de abril de 2018 de Windows 10
(versión 1803)
32 bits y 64 bits .NET Framework 4.7.2 .NET Framework 4.8
Windows 10 Fall Creators Update
(versión 1709)
32 bits y 64 bits .NET Framework 4.7.1 .NET Framework 4.7.2

.NET Framework 4.8
Windows 10 Creators Update
(versión 1703)
32 bits y 64 bits .NET Framework 4.7 .NET Framework 4.7.1

.NET Framework 4.7.2

.NET Framework 4.8
Actualización de aniversario de Windows 10
(versión 1607)
32 bits y 64 bits .NET Framework 4.6.2 .NET Framework 4.7

.NET Framework 4.7.1

.NET Framework 4.7.2

.NET Framework 4.8
Actualización de noviembre de Windows 10
(versión 1511)
32 bits y 64 bits .NET Framework 4.6.1 .NET Framework 4.6.2
Windows 10
(versión 1507)
32 bits y 64 bits .NET Framework 4.6 .NET Framework 4.6.1

.NET Framework 4.6.2
Windows 8.1 32 bits, 64 bits y ARM .NET Framework 4.5.1 .NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

.NET Framework 4.7

.NET Framework 4.7.1

.NET Framework 4.7.2

.NET Framework 4.8
Windows 8 32 bits, 64 bits y ARM .NET Framework 4.5 .NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.1
Windows 7 SP1 32 bits y 64 bits -- .NET Framework 4

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

.NET Framework 4.7

.NET Framework 4.7.1

.NET Framework 4.7.2

.NET Framework 4.8
Windows Vista SP2 32 bits y 64 bits -- .NET Framework 4

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6
Windows XP 32 bits y 64 bits -- .NET Framework 4

Notas:

  • En sistemas con Windows 7, tenga en cuenta que .NET Framework requiere Windows 7 SP1. Si usa Windows 7 y aún no ha instalado Service Pack 1, debe hacerlo antes de instalar .NET Framework.

  • .NET Framework 4.5 se admite en el Entorno de preinstalación de Windows (Windows PE). No todas las características se admiten en Windows PE.

  • .NET Framework 4 también es compatible con la plataforma IA64.

  • Para todas las plataformas, se recomienda actualizar al último Service Pack de Windows e instalar las actualizaciones críticas disponibles de Windows Update para garantizar la máxima compatibilidad y seguridad.

  • En sistemas operativos de 64 bits, .NET Framework admite WOW64 (procesamiento de 32 bits en un equipo de 64 bits) y el procesamiento nativo de 64 bits.

Sistemas operativos de servidor admitidos

Sistema operativo Ediciones compatibles Preinstalado con el sistema operativo Instalable por separado
Windows Server 2022 64 bits .NET Framework 4.8 .NET Framework 4.8.1
Windows Server 2019 64 bits .NET Framework 4.7.2 .NET Framework 4.8
Windows Server, versión 1809 64 bits .NET Framework 4.7.2 .NET Framework 4.8
Windows Server, versión 1803 64 bits .NET Framework 4.7.2 .NET Framework 4.8
Windows Server, versión 1709 64 bits .NET Framework 4.7.1 .NET Framework 4.7.2
Windows Server 2016 64 bits .NET Framework 4.6.2 .NET Framework 4.7

.NET Framework 4.7.1

.NET Framework 4.7.2

.NET Framework 4.8
Windows Server 2012 R2 64 bits .NET Framework 4.5.1 .NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

.NET Framework 4.7

.NET Framework 4.7.1

.NET Framework 4.7.2

.NET Framework 4.8
Windows Server 2012 (edición de 64 bits) 64 bits .NET Framework 4.5 .NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

.NET Framework 4.7

.NET Framework 4.7.1

.NET Framework 4.7.2

.NET Framework 4.8
Windows Server 2008 R2 SP1 64 bits -- .NET Framework 4

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

.NET Framework 4.7

.NET Framework 4.7.1

.NET Framework 4.7.2

.NET Framework 4.8
Windows Server 2008 SP2 32 bits y 64 bits -- .NET Framework 4

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET Framework 4.6

.NET Framework 4.6.2

Notas:

  • Windows Server 2012 incluye .NET Framework 4.5, por lo que no tendrá que instalarlo aparte. De forma similar, Windows Server 2012 R2 incluye .NET Framework 4.5.1.

  • .NET Framework. tiene compatibilidad limitada con el rol Server Core con Windows Server 2008 R2 SP1 o versiones posteriores. Vea Server Core .NET Functionality (Funcionalidad de .NET en Server Core) para obtener una lista de las API no compatibles.

  • .NET Framework no se admite en Windows Server 2008 R2 for Itanium-Based Systems.

  • En Windows Server 2008 SP2, .NET Framework no se admite en el rol Server Core.

  • Para todas las plataformas, se recomienda actualizar al último Service Pack de Windows y las actualizaciones críticas disponibles de Windows Update para garantizar la máxima compatibilidad y seguridad. La instalación del último Service Pack de Windows puede ser necesaria en algunos sistemas operativos.

  • En sistemas operativos de 64 bits, .NET Framework admite WOW64 (procesamiento de 32 bits en un equipo de 64 bits) y el procesamiento nativo de 64 bits.

Vea también