Nota:
El acceso a esta página requiere autorización. Puede intentar iniciar sesión o cambiar directorios.
El acceso a esta página requiere autorización. Puede intentar cambiar los directorios.
Este artículo le ayuda a diagnosticar y resolver problemas comunes al usar Microsoft Entra Backup and Recovery, incluido el acceso de copia de seguridad, los trabajos de informe de diferencias y los trabajos de recuperación.
Antes de empezar
Compruebe estos requisitos previos antes de solucionar problemas:
- El usuario es un usuario de gestión del personal (no se admiten identificadores externos ni usuarios B2C).
- El inquilino tiene licencias de Microsoft Entra ID P1 o P2 .
- Ha iniciado sesión con una cuenta que tenga el rol de Copia de seguridad de Microsoft Entra adecuado:
- Lector de copia de seguridad de Microsoft Entra
- Administrador de Microsoft Entra Backup
El rol Administrador global también tiene los permisos necesarios.
Si no se cumplen estos requisitos previos, es posible que las operaciones produzcan errores de autorización o resultados vacíos.
Problema: No se muestran copias de seguridad
Este problema se produce cuando la lista de copia de seguridad muestra menos copias de seguridad de las esperadas o muestra marcas de tiempo duplicadas.
Síntomas
- Hay menos de siete días de copias de seguridad visibles, en lugar de los siete días esperados.
- Dos o más copias de seguridad parecen tener la misma marca de tiempo en la lista de copias de seguridad.
Causas posibles:
La copia de seguridad más antigua podría agotarse antes durante la inicialización del servicio, la incorporación de inquilinos o las condiciones de back-end transitorias, lo que da lugar temporalmente a menos de siete días visibles de copias de seguridad. Esta condición no indica la pérdida de datos ni un error de copia de seguridad.
Resolution
No hace falta realizar ninguna acción. El servicio continúa creando nuevas copias de seguridad automáticamente.
Problema: no se puede iniciar un informe de comparativa o un trabajo de recuperación
Este problema se produce cuando no se inicia un informe de diferencias o un trabajo de recuperación debido a un conflicto, un error de autorización o un tipo de objeto no admitido.
Síntomas
- No se puede iniciar el informe de diferencias o el trabajo de recuperación.
- Un error indica un error de autorización o conflicto.
- El tipo de objeto que desea usar no aparece en la lista desplegable de filtro de ámbito.
Causas posibles:
- Ya se está ejecutando otro informe o trabajo de recuperación de diferencias.
- El usuario que ha iniciado sesión no tiene el rol de Microsoft Entra Backup necesario.
- El tipo de objeto seleccionado no se admite para la copia de seguridad y recuperación en la versión actual.
Resolution
- Compruebe si se está ejecutando otro reporte de diferencias o trabajo de recuperación. Solo se puede ejecutar un trabajo a la vez.
- Compruebe que su cuenta tiene el rol adecuado: Lector de copia de seguridad de Microsoft Entra para informes de diferencias o Administrador de Microsoft Entra Backup para la recuperación.
- Confirme que se admiten el tipo de objeto y los atributos de objeto que intenta limitar. Solo aparecen los tipos de objeto y atributos admitidos en el filtro de ámbito.
Problema: Problemas de informe de diferencias
Esta sección ayuda a solucionar problemas comunes relacionados con los informes de diferencias, incluidos los cambios que faltan, los trabajos de ejecución prolongada, los trabajos con errores, los trabajos cancelados y los informes que faltan.
Síntomas
- El informe de diferencias no incluía los cambios para el objeto que estaba buscando.
- El informe de diferencias se ha estado ejecutando durante varias horas y no sabes cuándo terminará.
- El estado del informe de diferencia es "Fallido".
- No puedes encontrar el informe de diferencias que generaste anteriormente.
- Ha seleccionado Cancelar, pero parece que el informe de diferencias sigue ejecutándose.
Causas posibles:
- El objeto o la propiedad no son compatibles para vista previa en la versión actual de lanzamiento.
- El objeto no cambió entre el estado de copia de seguridad y el estado actual.
- El informe de diferencias está procesando una gran cantidad de objetos o cambios.
- Solo se puede ejecutar un reporte de diferencias o un trabajo de recuperación a la vez.
- El informe se canceló o produjo un error antes de la finalización.
- Los informes de diferencias no se conservan indefinidamente.
Resolution
Si faltan los cambios esperados:
- Confirme que el tipo de objeto y las propiedades son compatibles con la versión actual.
- Compruebe que el objeto cambió después de realizar la copia de seguridad.
- No se incluyen objetos eliminados de forma permanente ni propiedades no admitidas.
Si el informe de diferencias se está ejecutando durante mucho tiempo:
Consulte el tiempo de generación del informe de diferencias estimado. Los inquilinos grandes o grandes lotes de cambios pueden tardar más en procesarse.
- Permita que el informe continúe ejecutándose a menos que se requiera la cancelación.
Si se produjo un error en el informe de diferencias:
- Revise el estado del trabajo y el mensaje de error que se muestra en los detalles del informe.
- Vuelva a intentar el informe de diferencias mediante un ámbito más estrecho, como un tipo de objeto específico o un identificador de objeto.
- Asegúrese de que ningún otro informe o trabajo de recuperación de diferencias se esté ejecutando al mismo tiempo.
Si no encuentra un informe de diferencias anterior:
Los informes de diferencias están vinculados a la copia de seguridad de la que se crearon.
- Vaya a la copia de seguridad y compruebe la lista de trabajos de informe de diferencias asociados.
- Si el informe no aparece en la lista, es posible que ya no esté disponible porque los informes de diferencias se conservan durante siete días después de su fecha de finalización.
Si el informe de diferencias continúa ejecutándose después de la cancelación:
- La cancelación es el mejor esfuerzo. Es posible que algunos procesamientos continúen brevemente después de seleccionar Cancelar.
- Si el trabajo permanece en un estado en ejecución, espere a que el estado se actualice antes de iniciar un nuevo informe.
Problema: Incidentes en trabajos de recuperación
Este problema se produce cuando un trabajo de recuperación no recupera los objetos esperados, se ejecuta más de lo esperado o se completa con advertencias.
Síntomas
- El trabajo de recuperación no logró recuperar un objeto que aparecía en el informe de diferencias.
- El trabajo de recuperación se ha estado ejecutando durante varias horas y no sabes cuándo terminará.
- El estado del trabajo de recuperación es "Completado con advertencias".
- Canceló el trabajo de recuperación, pero el trabajo todavía parece estar en ejecución.
Causas posibles:
- El objeto o la propiedad que se muestra en el informe de diferencias (por ejemplo, propiedades sincronizadas locales) no es compatible con la recuperación.
- El trabajo de recuperación incluye un gran número de objetos o cambios.
- Solo se puede ejecutar un reporte de diferencias o un trabajo de recuperación a la vez.
- El trabajo de recuperación se canceló o interrumpió mientras se procesaban los cambios.
- Algunas acciones de recuperación pueden realizarse parcialmente antes de que se produzca un error o una cancelación.
Resolution
- Revise la lista de cambios fallidos en los detalles de la tarea de recuperación.
- Vuelva a intentar la recuperación con un ámbito más estrecho, centrándose en objetos solo en la nube admitidos.
Problema: no se encuentra un trabajo de recuperación o no se han recuperado todos los vínculos.
Este problema se produce cuando un trabajo de recuperación completado anteriormente ya no está visible o cuando solo se recuperaron algunos vínculos.
Síntomas
- No puedes encontrar el trabajo de recuperación que ejecutaste ayer.
- El trabajo de recuperación muestra que solo se recuperaron algunos vínculos o propiedades (por ejemplo, 1 de cada 5) y otros no.
Causas posibles:
- Los detalles del trabajo de recuperación se eliminan automáticamente siete días después de que se complete el trabajo.
- Algunos enlaces no son compatibles con la recuperación en la versión actual.
- Algunos vínculos dependen de otros objetos o estados que ya no existen.
- El trabajo de recuperación se completó con advertencias, lo que indica un éxito parcial.
Resolution
Si no encuentra un trabajo de recuperación que ejecutó anteriormente:
- Busque la marca de tiempo de copia de seguridad que se usó para la recuperación.
- Revise el historial de recuperación para buscar trabajos de recuperación asociados a esa marca de tiempo de copia de seguridad.
- Si el trabajo ya no aparece, es posible que ya no esté disponible porque los trabajos de recuperación se conservan durante siete días después de su fecha de finalización.
Si no se recuperaron todos los vínculos:
- Revise los detalles del trabajo de recuperación para ver las advertencias o los cambios de vínculo con errores.
- Confirme que los vínculos que esperaba recuperar se admiten en la versión actual.
- Es posible que algunos vínculos no se recuperen si:
- El objeto relacionado ya no existe.
- No se admite el tipo de vínculo.
- Vuelva a crear manualmente los vínculos no admitidos o con errores si es necesario.
Condiciones de error y mensajes
| Condición | Código de error y mensaje |
|---|---|
| Informe de diferencias consultado con un ID de copia de seguridad no válido | 404 No encontrado: esta no es una marca de tiempo válida para la recuperación de datos. La marca de tiempo proporcionada debe estar en la lista de copias de seguridad disponibles. |
| Un trabajo es consultado con un ID de trabajo no válido | 404 No encontrado |
| Se inicia un trabajo mientras se está ejecutando otro informe o trabajo de recuperación de diferencias | 409 Conflicto: Actualmente hay un proceso de recuperación en curso. Espere a que se complete antes de iniciar un nuevo trabajo. |
| Obtener cambios mientras el informe de diferencias no se ha completado |
400 Solicitud incorrecta: el trabajo con identificador {key} debe haberse completado correctamente antes de enumerar los cambios. |
| Rol de administrador insuficiente | 403 Prohibido: se ha denegado la autorización para esta solicitud. Compruebe sus credenciales. |
Limitaciones conocidas
Las siguientes limitaciones conocidas se aplican a Microsoft Entra copia de seguridad y recuperación en esta versión.
Cobertura parcial de propiedades
La copia de seguridad y la recuperación no cubren todas las propiedades de los objetos admitidos. Esta limitación incluye propiedades de solo lectura, propiedades generadas por el sistema y propiedades que dependen de la lógica de negocios especializada. Consulte la lista de propiedades admitidas para obtener más información. Microsoft está ampliando el soporte para más propiedades a lo largo del tiempo.
Ámbito de soporte para clientes
Microsoft Entra Backup and Recovery solo se admite para los inquilinos empresariales. No se admiten el ID externo ni los tenant B2C.
Objetos eliminados de forma permanente
No se pueden recuperar objetos eliminados de forma permanente. Estos objetos no se incluyen en el informe de diferencias y no se pueden volver a crear ni restaurar mediante un trabajo de recuperación. Para reducir el riesgo de eliminación dura, considere la posibilidad de configurar acciones protegidas.
Objetos sincronizados locales
Los usuarios y grupos sincronizados desde Active Directory local no se pueden recuperar con Microsoft Entra Backup and Recovery. Estos objetos se deben recuperar directamente en el entorno de Active Directory local.
Limitaciones de recuperación de vínculos
Solo se admiten vínculos de pertenencia a grupos estáticos para la recuperación. No se admiten vínculos de dueño del grupo, relaciones de gestión de usuarios ni vínculos de patrocinador.