Exchange Online los usuarios no pueden acceder a la información de disponibilidad de los usuarios en un sitio de Active Directory que no es accesible desde Internet

Nota:

Ya no se admite el Asistente para configuración híbrida que se incluye en el Consola de administración de Exchange de Microsoft Exchange Server 2010. Por lo tanto, ya no debe usar el asistente de configuración híbrida anterior. En su lugar, use el Asistente para configuración híbrida de Microsoft 365 que está disponible en https://aka.ms/HybridWizard. Para obtener más información, vea Asistente para configuración híbrida de Microsoft 365 para Exchange 2010.

Número de KB original: 3057905

Síntomas

Imagine la siguiente situación:

  • Tiene una implementación híbrida de Microsoft Exchange Online y Microsoft Exchange Server locales.
  • El entorno híbrido tiene dos sitios de Active Directory.
  • Un sitio de Active Directory está orientado a Internet y el otro sitio no está orientado a Internet.

En este escenario, los usuarios que tienen buzones en Exchange Online no pueden acceder a la información de disponibilidad de los usuarios locales que tienen buzones en el sitio de Active Directory que no es accesible desde Internet.

Además, una entrada de identificador de evento 4002 similar a la siguiente se registra en el registro de aplicaciones cada vez que un buzón de Exchange Online en el sitio accesible desde Internet realiza una solicitud de disponibilidad a un buzón local en el sitio que no es accesible desde Internet.

Nombre del registro: Aplicación
Origen: Disponibilidad de MSExchange
Identificador de evento: 4002
Categoría de tarea: Servicio de disponibilidad
Nivel: Error
Palabras clave: Clásico
Usuario: N/A
Equipo: <InternetfacingServer.domain.com>
Descripción:
Proceso 6424: ProxyWebRequest CrossSite de UserA@contoso.mail.onmicrosoft.com a https://<FQDN of non-Internet-facing Exchange>:443/ews/exchange.asmx failed. SID del autor de la llamada: WSSecurity. La excepción devuelta es
Microsoft.Exchange.InfoWorker.Common.Availability.ProxyWebRequestProcessingException:
System.Net.WebException: se cerró la conexión subyacente: se produjo un error inesperado en una recepción.
>--- System.IO.IOException: No se pueden leer datos de la conexión de transporte: una conexión existente
fue cerrado por la fuerza por el host remoto. >--- System.Net.Sockets.SocketException: una conexión existente
fue cerrado por la fuerza por el host remoto
at System.Net.Sockets.Socket.EndReceive(IAsyncResult asyncResult)
at System.Net.Sockets.NetworkStream.EndRead(IAsyncResult asyncResult)
--- final del seguimiento de la pila de excepciones interna ---
at System.Net.Security._SslStream.EndRead(IAsyncResult asyncResult)
at System.Net.TlsStream.EndRead(IAsyncResult asyncResult)
at System.Net.PooledStream.EndRead(IAsyncResult asyncResult)
at System.Net.Connection.ReadCallback(IAsyncResult asyncResult)
--- final del seguimiento de la pila de excepciones interna ---
at System.Web.Services.Protocols.WebClientAsyncResult.WaitForResponse()
at System.Web.Services.Protocols.WebClientProtocol.EndSend(IAsyncResult asyncResult,
Objeto& internalAsyncState, Stream& responseStream)
at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
at Microsoft.Exchange.InfoWorker.Common.Availability.Proxy.Service.EndGetUserAvailability(IAsyncResult asyncResult)
at Microsoft.Exchange.InfoWorker.Common.Availability.FreeBusyApplication.EndProxyWebRequest(ProxyWebRequest proxyWebRequest, QueryList queryList, Service service, IAsyncResult asyncResult)
at Microsoft.Exchange.InfoWorker.Common.Availability.ProxyWebRequest.EndInvoke(IAsyncResult asyncResult)
at Microsoft.Exchange.InfoWorker.Common.Availability.AsyncWebRequest.EndInvokeWithErrorHandling():<No response>. La información de la solicitud es de tipo ProxyWebRequest = CrossSite, url = https://FQDN de Exchange>:443/ews/exchange.asmx
Lista de buzones = <Usuario B>SMTP:UserB@fabrikam.com, Parámetros: windowStart = DateTime, windowEnd = DateTime, MergedFBInterval = 30, RequestedView = Detailed. >--- System.Net.WebException: Se cerró la conexión subyacente: Se produjo un error inesperado en
una recepción. >--- System.IO.IOException: No se pueden leer datos de la conexión de transporte: el host remoto cerró forzadamente una conexión existente. >--- System.Net.Sockets.SocketException: el host remoto cerró forzadamente una conexión existente.
at System.Net.Sockets.Socket.EndReceive(IAsyncResult asyncResult)
at System.Net.Sockets.NetworkStream.EndRead(IAsyncResult asyncResult)
--- final del seguimiento de la pila de excepciones interna ---
at System.Net.Security._SslStream.EndRead(IAsyncResult asyncResult)
at System.Net.TlsStream.EndRead(IAsyncResult asyncResult)
at System.Net.PooledStream.EndRead(IAsyncResult asyncResult)
at System.Net.Connection.ReadCallback(IAsyncResult asyncResult)
--- final del seguimiento de la pila de excepciones interna ---
at System.Web.Services.Protocols.WebClientAsyncResult.WaitForResponse()
at System.Web.Services.Protocols.WebClientProtocol.EndSend(IAsyncResult asyncResult, Object& internalAsyncState, Stream& responseStream)
at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
at Microsoft.Exchange.InfoWorker.Common.Availability.Proxy.Service.EndGetUserAvailability(IAsyncResult asyncResult)
at Microsoft.Exchange.InfoWorker.Common.Availability.FreeBusyApplication.EndProxyWebRequest (ProxyWebRequest proxyWebRequest, QueryList queryList, Service service, IAsyncResult asyncResult)
at Microsoft.Exchange.InfoWorker.Common.Availability.ProxyWebRequest.EndInvoke(IAsyncResult asyncResult)
at Microsoft.Exchange.InfoWorker.Common.Availability.AsyncWebRequest.EndInvokeWithErrorHandling()
--- final del seguimiento de la pila de excepciones interna ---
. Nombre del servidor donde se originó la excepción: <nombre de host del sitio> accesible desde Internet.

Asegúrese de que el sitio o bosque de Active Directory que contiene el buzón del usuario tiene al menos un servidor local que ejecuta Exchange Server que también ejecuta el servicio de disponibilidad. Active el registro para el servicio de disponibilidad y, a continuación, pruebe la conectividad de red básica.

Causa

El certificado que se usa para crear la federación con Exchange Online no está instalado en los servidores de Exchange del sitio que no es accesible desde Internet.

Solución

Exporte los certificados de federación desde los servidores exchange accesibles desde Internet y, a continuación, impórtelos en los servidores exchange que no tienen conexión a Internet.

Más información

Para obtener más información sobre cómo exportar certificados en Exchange Server, consulte los siguientes recursos:

¿Aún necesita ayuda? Vaya a Microsoft Community o a las preguntas frecuentes de Microsoft.