Compartir a través de


Los mensajes de correo electrónico salientes no se envían en el servidor perimetral o de transporte de Exchange Hub

Número de KB original: 4051498

Síntomas

Al examinar el estado de la cola, observa el siguiente mensaje de error:

La dirección IP de destino principal 451 4.4.0 respondió con: "Se agotó el tiempo de espera de la conexión 421 4.4.1". Intentó conmutar por error a un host alternativo, pero eso no se realizó correctamente. No hay hosts alternativos o no se pudo entregar a todos los hosts alternativos.

Además, la siguiente entrada se registra en Los registros del conector de envío si el registro está habilitado:

Error desconocido en la negociación de TLSCredentials.

Causa

Este problema se produce si un certificado de terceros instalado en el servidor que ejecuta Exchange Server no está enlazado al servicio SMTP.

Solución

Para resolver este problema, enlace el certificado de terceros al servicio SMTP. Para ello, siga estos pasos:

  1. Habilite el registro en el conector de envío. Para comprobarlo, ejecute el siguiente comando:

    Set-SendConnector "<SendConnectorName>" -ProtocolLoggingLevel Verbose
    
  2. En Send connector logs (Enviar registros del conector), busque la huella digital del certificado TLS. Registro de ejemplo:

    2017-10-07T04:42:56.804Z,Saliente a Office 365,08D50D3D9730A8D2,16,10.10.248.7:16547,216.32.181.234:25,*,"CN=*.domain.com, OU=Enterprise SSL Wildcard, OU=Contoso IT, O=Contoso Corporation",Certificate subject
    2017-10-07T04:42:56.804Z,Outbound to Office 365,08D50D3D9730A8D2,17,10.10.248.7:16547,216.32.181.234:25,*,"CN=Entidad de certificación segura de confianza 5, O=Empresa de servicios de corporation, L=Wilmington, S=DE, C=US",Nombre del emisor del certificado
    2017-10-07T04:42:56.804Z,Saliente a Office 365,08D50D3D9730A8D2,18 ,10.10.248.7:16547,216.32.181.234:25,*,xxxxxxxxxxxxxxxxxxxxxx,Número de serie del certificado
    2017-10-07T04:42:56.804Z,Saliente a Office 365,08D50D3D9730A8D2,19,10.10.248.7:16547,216.32.181.234:25,*,xxxxxxxxxxxxxxxxxxxxxx,Huella digital del certificado
    2017-10-07T04:42:56.804Z,Saliente a Office 365,08D50D3D9730A8D2,20, 10.10.248.7:16547,216.32.181.234:25,*,*.domai.com;,conotso.comCertificate alternate names
    2017-10-07T04:42:56.804Z,Saliente a Office 365,08D50D3D9730A8D2,21 10.10.248.7:16547,216.32.181.234:25,*,No se pudo negociar TLS con el error UnknownCredentials

  3. Compruebe los servicios asociados al certificado TLS. Para ello, ejecute el siguiente comando. Los nombres de los servicios se usan en el paso siguiente.

    Get-ExchangeCertificate -ThumbPrint "<TLSCertThumbprint>" | select-object services
    
  4. Enlace el certificado al servicio SMTP. Para comprobarlo, ejecute el siguiente comando:

    Enable-ExchangeCertificate -ThumbPrint "<TLSCertThumbprint>" -services <ServicesNames>
    

    Ejemplo:

    Enable-ExchangeCertificate -ThumbPrint "xxxxxxxxxxxxxxxxxxxx" -services SMTP,IIS,POP
    
  5. En el símbolo del sistema para reemplazar el certificado existente mediante el nuevo certificado, escriba N y, a continuación, presione Entrar.