Compartir a través de


Faltan carpetas favoritos en el cliente de Outlook después de la migración a Exchange Online

Síntomas

Imagine la siguiente situación:

  • Migre un buzón de usuario local a Microsoft Exchange Online.

  • Después de la migración, el usuario del buzón crea un nuevo perfil de Microsoft Outlook.

En ese escenario, las carpetas que aparecían como Favoritos antes de la migración ya no aparecen como Favoritos en el cliente de Outlook.

Outlook en la Web no se ve afectado por este problema.

Causa

Cada carpeta Favoritos tiene un MailboxDN valor de campo dentro del valor de propiedad PR_WLINK_STORE_ENTRYID que asocia la carpeta con el buzón. Antes de la migración del buzón de correo, el valor del MailboxDN campo refleja el LegacyExchangeDN valor de propiedad del buzón local.

Cuando el buzón se migra a la nube, Exchange Online aplica un nuevo LegacyExchangeDN valor al buzón de correo en la nube. Sin embargo, Exchange Online no actualiza el MailboxDN valor de campo de cada carpeta Favoritos al nuevo LegacyExchangeDN valor. Si el usuario del buzón de correo continúa usando su perfil de Outlook existente después de la migración, las carpetas Favoritos aparecen como de costumbre en el cliente de Outlook. Sin embargo, si el usuario crea y usa un nuevo perfil de Outlook, la falta de coincidencia entre el MailboxDN valor de cada carpeta y el LegacyExchangeDN valor del buzón de Exchange Online hace que las carpetas Favoritos no aparezcan en el cliente de Outlook.

Solución alternativa

Para solucionar este problema, los usuarios del buzón pueden usar cualquiera de las siguientes soluciones alternativas.

Vuelva a agregar carpetas manualmente a Favoritos en el cliente de Outlook.

Solución alternativa 2

Use la herramienta MFCMAPI para actualizar manualmente el MailboxDN valor de cada carpeta que se debe agregar a Favoritos.

Siga estos pasos:

  1. Ejecute el siguiente comando para conectarse a Exchange Online PowerShell:

    Connect-ExchangeOnline
    
  2. Ejecute el siguiente comando para buscar el LegacyExchangeDN valor del buzón de Exchange Online:

    Get-Mailbox <mailbox SMTP address> | FL LegacyExchangeDN
    
  3. Determine si la instalación de Outlook es una versión de 32 o 64 bits comprobando La cuenta >de Archivo>de Officeacerca de Outlook.

  4. Descargue y extraiga la versión más reciente de MFCMAPI de 32 o 64 bits para que coincida con la instalación de Outlook.

    Importante

    Aunque se admite el editor MFCMAPI, debe tener cuidado al usar esta herramienta para cambiar los buzones. El uso incorrecto del editor MFCMAPI puede provocar daños permanentes en un buzón.

  5. Asegúrese de que Outlook está cerrado y, a continuación, ejecute MFCMapi.exe. Si aparece la pantalla de inicio de MFCMAPI, ciérrela.

  6. Seleccione Inicio de sesión> para abrir la ventana Elegir perfil.

  7. Seleccione el perfil de Outlook para el buzón del usuario y, a continuación, seleccione Aceptar.

  8. Haga doble clic en la dirección SMTP del buzón en la columna Nombre para mostrar para abrir la ventana Buzón raíz del buzón.

  9. En el panel izquierdo, seleccioneVistas comunesdel buzón de correo> raíz.

  10. En el panel derecho, haga doble clic en PR_FOLDER_ASSOCIATED_CONTENTS para abrir la tabla Contenido asociado .

  11. Para cada carpeta que no aparezca en la lista Favoritos, siga estos pasos:

    1. Haga doble clic en el nombre de la carpeta en la columna PR_SUBJECT para abrir la ventana Propiedades de la carpeta.

    2. Haga doble clic en la entrada PR_WLINK_STORE_ENTRYID de la columna Nombre para abrir la ventana Editor propiedad.

    3. En la sección Vista inteligente, seleccione el campo EntryIDMAPI Message Store Entry IDMailboxDN (Id. de entrada del almacén de mensajes MAPI EntryID >>MailboxDN). El valor del campo corresponde al LegacyExchangeDN valor del buzón local antes de la migración.

    4. En la sección Texto , actualice el valor MailboxDN para que coincida con el valor actual LegacyExchangeDN del buzón que obtuvo en el paso 2.

  12. Cierre todas las ventanas MFCMAPI para salir de la aplicación.

  13. Inicie Outlook y compruebe que se restaura la colección de carpetas Favoritos que tenía antes de la migración.