Nota
El acceso a esta página requiere autorización. Puede intentar iniciar sesión o cambiar directorios.
El acceso a esta página requiere autorización. Puede intentar cambiar los directorios.
Síntomas
Considere el caso siguiente:
Migre un buzón de usuario local a Microsoft Exchange Online.
Después de la migración, el usuario del buzón crea un nuevo perfil de Microsoft Outlook.
En ese escenario, las carpetas que se mostraron como Favoritos antes de la migración ya no aparecen como Favoritos en el cliente de Outlook.
Outlook en la Web no tiene este problema.
Causa
Cada carpeta Favoritos tiene un MailboxDN
valor de campo dentro del valor de propiedad PR_WLINK_STORE_ENTRYID
que asocia la carpeta con el buzón de correo. Antes de la migración del buzón, el valor del campo MailboxDN
refleja la propiedad LegacyExchangeDN
del buzón local.
Cuando el buzón se migra a la nube, Exchange Online aplica un nuevo LegacyExchangeDN
valor al buzón en la nube. Sin embargo, Exchange Online no actualiza el MailboxDN
valor de campo de cada carpeta Favoritos al nuevo LegacyExchangeDN
valor. Si el usuario del buzón sigue usando su perfil de Outlook existente después de la migración, las carpetas Favoritos aparecen como de costumbre en el cliente de Outlook. Sin embargo, si el usuario crea y usa un nuevo perfil de Outlook, la falta de coincidencia entre el MailboxDN
valor de cada carpeta y el LegacyExchangeDN
valor del buzón de Exchange Online hace que las carpetas Favoritos no aparezcan en el cliente de Outlook.
Solución
Para solucionar este problema, los usuarios del buzón pueden usar cualquiera de las siguientes soluciones alternativas.
Solución alternativa 1 (recomendado)
Vuelva a agregar manualmente carpetas a Favoritos en el cliente de Outlook.
Solución alternativa 2
Use la herramienta MFCMAPI para actualizar manualmente el MailboxDN
valor de cada carpeta que debe aparecer en la lista Favoritos.
Importante
Aunque se admite el editor MFCMAPI, debe tener cuidado al usar esta herramienta para cambiar los buzones. El uso del editor MFCMAPI incorrectamente puede causar daños permanentes en un buzón.
Siga estos pasos en el nuevo perfil del usuario:
Anote el nombre de una carpeta Favoritos que está visible. Si no hay ninguna visible, agregue una carpeta a Favoritos para crear una carpeta visible.
Anote los nombres de todas las carpetas Favoritos que no aparecen en la lista Favoritos.
Para la carpeta Favoritos que aparece en la lista Favoritos:
Copie el valor hexadecimal de la sección Binary del editor.
Seleccione Cancelar para cerrar el editor y, a continuación, cierre la ventana Propiedades de la carpeta.
Para cada carpeta Favoritos que no aparezca en la lista Favoritos, realice los pasos siguientes:
Reemplace todo el valor hexadecimal de la sección Binary del editor por el valor hexadecimal que copió en el paso 4.
Seleccione Aceptar para guardar el valor y cerrar el editor y, a continuación, cierre la ventana Propiedades de la carpeta.
Cierre todas las ventanas MFCMAPI para salir de la aplicación.
Inicie Outlook y compruebe que se restaure la colección de carpetas Favoritos que tenía antes de la migración.
Procedimientos comunes de MFCMAPI
Abrir la tabla de contenido asociada en MFCMAPI
Si aún no tiene MFCMAPI instalado, siga estos pasos:
Determine si la instalación de Outlook es una versión de 32 o 64 bits comprobando Archivo>cuenta de Office>Acerca de Outlook.
Descargue y extraiga la versión MFCMAPI de 32 o 64 bits más reciente para que coincida con la instalación de Outlook.
Asegúrese de que Outlook está cerrado y, a continuación, ejecute MFCMapi.exe. Si aparece la pantalla de inicio MFCMAPI, ciérrala.
Seleccione Inicio de Sesión> para abrir la ventana Elegir perfil.
Seleccione el nuevo perfil para el buzón del usuario y, a continuación, seleccione Aceptar.
Haga doble clic en la dirección SMTP del buzón en la columna Nombre para mostrar para abrir la ventana Buzón raíz del buzón.
En el panel izquierdo, seleccione Root Mailbox>Vistas Comunes para abrir la vista aplicable del panel derecho.
En el panel derecho, haga doble clic en PR_FOLDER_ASSOCIATED_CONTENTS para abrir la tabla Contenido asociado .
Abra el editor de PR_WLINK_STORE_ENTRYID para una carpeta.
En la tabla Contenido asociado , busque el nombre de la carpeta en la columna PR_SUBJECT .
Haga doble clic en el nombre de la carpeta para abrir su ventana Propiedades .
En la ventana Propiedades , haga doble clic en la entrada PR_WLINK_STORE_ENTRYID de la columna Nombre . Se abrirá la ventana Editor de propiedades de la carpeta.